AirPlay no longer working


Any reason why the Airplay stopped working?

It might have happened after the last update.

Anyone got the same issue and get it fixed?

I have an iPhone X and I could connect my videos through Airplay to my PicoPix before.

Thanks! :slight_smile:


Another technical question: is the Airplay option related to a specific piece of hardware or, for example, it depends on the Bluetooth or Wifi piece of hardware?

Just to understand if it could be a software issue or hardware…

Both your projector and your phone needs to be connected to the same wifi modem/router, is your wifi on for all devices or have you made any changes to your wifi?

Have you started the mirroring app at least once after updating? (Projector Settings > Mirroring > Apple)

@Philips_Support_P I was wondering if it can be started as a service or auto launched and close as a part of initial setup/factory reset/upgrade to avoid confusion as customer experience?

I talked to the streaming app vendor about this and found that:

The mirroring app must be started at least once. On this first try, the background service is installed. But in Android 9 it is not possible to install a service without at least starting the app once.

Actually in some of our other products the mirroring feature is only active if you explicitly start it. (similar e.g. in FireTV the Miracast is only active if you manually start it).


Yes, they are both connected to the same wifi and I clicked on Projector Settings > Mirroring> iOS.

It’s doesn’t show up yet.

If once I clicked on “iOS” I turn off and turn on the projector, is the mirroring already active or I have to go click on it and start the mirroring again?

Everything else is working properly. Is the mirroring hardware or software side?

It’s software, so whatever is causing the issue is solvable I reckon.

Is your iPhone up to date?

Good to hear that. Yes, everything is up to date

Check if ExpressVPN is active?

I uninstalled it. But installed NordVPN which is not connected

I received my ppm on Tuesday and can also confirm your issue. I can connect to the ppm airplay, but even my Videos from the Foto app will not be played. I hear the sound but con not see any picture. From other apps (even YouTube) the videos and the sound did not start.

All devices are updated.

By the way: are there any news to the integration of the airplay2 standard?

1 Like

I just made a factory reset and started again everything. Nothing has changed. It’s still not working.

Is it 100% it could only be a software side issue?

[UPDATE] I found out what it was the problem. Apparently it was the wifi router. I tried to connect the projector and the iphone to a different wifi router and the airplay is now working.

I don’t know yet why I cannot connect from the main wifi router but glad to know that it’s working.


Yes! I had the same issue, thank you for your remark now it’s working also for me.


Hey I just opened up my pico and started it for the first time and I cant even get my phone to find the pico device

Are they both on the same WiFi network?

Airplay working well from my MacBook. Sky working well. image