Amazon Prime Video won't play videos (D-pad center button does nothing)

I tried using the Amazon Prime Video app (on firmware 1.0.25). I can navigate the available options using the D-pad, but the D-pad center button does nothing in this app, so videos cannot be selected for playback. You have to reach for the touchpad on the top of the projector to click on video links. The D-pad must be generating the wrong keycode or something.

This is a well known limitation because this is the tablette app, not Android TV so you have to use the airmote mouse. But I think you managed this looking at your other threads :wink:

If that were the case, why does the D-pad even work at all? It’s not just a tablet app, it has keyboard support.

I tested this by plugging in a USB keyboard to the PPM, and discovered the issue. The D-pad on the remote appears to generate the Enter keycode. However you have to hit Tab on the keyboard before Enter can be used to select content for playback (even though before hitting Tab, you can browse up/down and left/right). There’s no Tab button on the remote, so it can’t initiate playback in this way.

Really the Amazon app should be fixed (only Amazon can do this) – but it makes me wonder how this works on other Android devices, because I’m sure D-pad input must work fine on some device. I’d be extremely surprised if D-pad input (without a Tab key) was never tested by the Amazon team.

You are right that the app is to blame but this fairly common for tablet/phone apps to have poor keyboard optimization as some elements are supposed to be touched/clicked.
Plex app is a good counter example of perfect optimization.
I’ve faced it many times when side loading app on Android TV.
Using the airmote is a bit counter intuitive but this is the only solution for this kind of apps.

Hi, just received mine here in Australia.
Netflix, Foxtel, Stan, SBS, ABC Iview are all working well (yay!)
The one persistent problem I have is Amazon Prime video.
I can browse the menus, but then get a message “Something went wrong. Please try again later. For more help go to”

System version is 1.0.27

Amazon prime version is 5.1.3-googleplay-armv7a

I have tried removing it, reinstalling it, clearing cache, all options.

Is there an earlier version of the Prime app I should be using?


I just sideloaded a v 3.0.264 amazon prime video apk and that is working fine. The interface isn’t as nice as the new one but at least it works!

Tried this as well, but it only worked once. After turning off/on the projector no picture @prime again. everthing else works great so far.

I’m using version of Prime without any issues, can you update to that one? Someone else tried it and indicated it was not in HD though…

@mjoyceau Can I ask what Foxtel
App you are using? If the main one highlighted on the screen after searching (the one I installed) how do you pause a show once it has started playing? It’s got me stumped…


I can log in prime Video,
it show me my watchlist but don´t play video, turning wheel when try to start movie, after a while Screenmessage App Failure. Please restart…

1 Like

Now installed with aptoide another Prime Video version, now it works :wink:

Which version number exactly?

Amazon Prime worked for me.

1 Like

Sometimes the Prime app wont play videos for me either, but thats usually when I have my VPN on, so make sure you turn it off

1 Like

I can´t really say which version it is, it´s a bit complicate. Because it didn´t worked in the beginning I tried to install with aptoide TV another version and also some other apps. When I did go back to the main menu some of the apps aren´t there but there were suddenly 2 prime vieo apps. In the main menu it don´t show which version it is.
When I go into the aptoide menu it shoes me only one prime video app in my apps but when I start this one it don´t work. I´m new to androide and maybe I did something wrong but somehow it´s weird.
I got another problem for what should open another thread but tell also now. I experienced yesterday while watching prime video starting big artefacts like totally pixelized. When starting new it dissapeared sometimes but came back. Next I tried to mirroring the movie from Computer with Airplay, worked somehow but pictures stuttered in between. On the computer was no stuttering… At the end I looked the movie on my Computer because was to ennoying. Another thing is the projector settings. Each time when I want to adjust the picture I have to go all the way back to the main screen and then do all the steps again to load a video. There must be an easier way to switch between projector settings and look video? Thanks in advance for advice. :wink: