Anyone using PPM to play movies from a network drive?

Hello, not familiar with Android at all. On Apple TV I can use Plex and DS Video to access my movies on the network drive. How do I do this on PPM? I tried downloading Plex but the app keeps going on wrong orientation ??

I tried VLC, but I get stuck at requiring a password for the SMB drive. I know the password but can’t log in for some reason.

I tried MX player pro, but I don’t see an option to access network drive…

Any advice would be appreciated thank you!

I am using Emby to do this and have no issues

I used Plex to access my network drive successfully. When you first install Plex on the PPM, it asks whether you want “mobile mode” or TV mode. That changes the orientation.

Just get my PPM (not convinced at the moment…) and i tried to connect VLC to my Synology NAS threw a SMB folder. All my Android phone/tablet do that easily but this PPM refuse my login/password. Have tried a lot but no it don’t want…
Anyone get this issue ?


Works fine here, wity VLC and Synology (SMB).
My password only contains letters and numbers no special symbols.

Connect under “Local Network”.

1 Like

I haven’t tried playing much from network drive yet, but have connected to my server via Kodi and verified that videos play in principle. I did the connection via DLNA for now (running minidlna on my server), haven’t tried out SMB for lack of time/need.

(I should look into VLC as well to decide what I find easier to access.)

@legacy this might sound trivial, but have you made sure there’s no mix up of any characters because if different keyboard layouts? Is the password prompt in VLC masked or can you see what you are typing? I know this sometimes happens to me with certain passwords when I forget whether the device I’m using has a QWERTZ or QWERTY layout for example.

1 Like

@rovrell I have some ./§ cahracter in my passords I will try with a “simplier”
@franzli I have test a lot : characters are show 1 second after typing for checking. I have set a USB keyboard, virtual keyboard etc… My phones have no issue :-/

I primarily use Kodi (because it has “Play from here” feature to play all files in a folder one after the other) to access files via samba to my dd-wrt router. X-plore will also navigate samba and either play files itself or open in VLC, MX Player, etc.

1 Like

@legacy how did it go?

I did it yesterday ! The explication is not very clear : I have del all character in username and password wich differ beetween AZERTY and QWERTY. For example I rename the synology user I have created : “ppm” to “pp” => miracle happened ! It’s like the “m” character typed and showed send in fact another character. I have not tested yet with finding and testibg the character wich is “behind” the true one etc because I was so happy to get it working i have watch 2-3 anime in a row :smiley:


It could also just be your typing because your posts here are filled with typos!

:rofl: :stuck_out_tongue_winking_eye:

Glad you got it working though!