Australian Owners - Foxtel Help Please

Hi all
Bit of a specific one this but hoping someone can help.
Any Aussie owners who use the Foxtel app?
I was using it fine a few months ago, worked perfectly. I haven’t used the PPM for a little while but with the warmer weather coming I plan a few backyard movie nights. So yesterday I got the PPM out and updated software to the latest version and tested everything. Suddenly now though when I go into the same Foxtel app it says it won’t work and I need Multiroom subscription. I am confused - and speaking with Foxtel this morning hasn’t helped at all.
Isn’t this just an app, like on my iphone or ipad. So why do I need a multiroom sub?
That said, I do recall Foxtel having a promo for a few months (Covid) where they gave multiroom for free so maybe that’s why it worked before?
Hoping someone has had a similar experience?

Is it the Foxtel Go app? I just tried on my phone and it works ok, and i only have 1 Box. Haven’t tried on the PPM yet

Check the casting section, that is when you need multiroom. Foxtel GO. Anytime. Anywhere. Your device.

I have Kayo (and Binge), which I know is different but probably uses same tech. I had to download the APK file separately and load using a USB. That fixed it after the update.