Battery/charger problem?

I finally received my Picopix Max projector last Friday. Thank you for that.

There appears to be something wrong with either the battery or the charger: the battery-status light on my Picopix keeps shining bright red, even though it’s connected to the charger for > 12 hours. So it seems like it doesn’t charge properly. After a full night of charging in the morning the light switches between blue and red blinking, which (according to other messages on this forum) should mean that something is wrong with the (provided) charger. I tried this for 2 consecutive nights, and both mornings the status-light was blinking red/blue alternatingly. The status light never turns blue continuously. From what I understand the normal charging time should be +/- 3 hrs.

Hi @mgodefrooij.
Welcome to this forum.

Good to know that you received your PPM, but actually you may have a problem because after receiving mine it needed 1,5h to be fully charged.
Can you confirm that you’ve used the provided charger (as you said) and the provided cable to ?
As said here :


by @PhilipsEngineering , the red/blue blinking is showing an issue with the power supply.

Yes, I can confirm that I am using the original provided charger. I emailed with support. They asked me to play the projector unplugged until it’s fully discharged and then to try and recharge it. Will do so tonight and report back what happens.

Okay, so yesterday evening I ran the projector unplugged until it was fully discharged. Afterwards I plugged it back in, and after 3 hours it was only charged 1 out of 3 blocks on the battery symbol (see first picture, time around midnight). After that I left the device charging overnight. When I checked again this morning the lights were blinking red/blue again, and the battery was still only charged about 1/3, even though it had been plugged in all night. See second picture.

The blinking red/blue only starts after the device is plugged in for a longer time (eg overnight). The first hours the status light is burning solid red (e.g. also during the first 3 hours of charging yesterday evening).

OK, your tests are tending to prove that something goes wrong with the charging chain Charger/Cable/PPM, but in order to identify the weak link, can you apply the process described in the knowledge base item below :

Thanks for your support. I went through all steps. The projector DOES power and DOES project. The problem is that it doesn’t seem to charge properly. When I connect the charger the status light turns RED and the charging icon does appear on the top-right of the screen. The problem is that after 3 hours is hasn’t even charged up to 1/3 of its capacity, and after charging for a full night it’s still only charged 1/3 and the status lights are blinking RED and BLUE alternatively, which (according to my understanding) means that something’s wrong with the charger. I checked different wall sockets. I also tried to charge the projector with another USB3 powerbank, but apparently the voltage of my powerbank is too low because nothing happens. The projector’s operating fine as long as it’s plugged in. The problem seems to be related to charging the battery.

Through email support I received a return ticket, so I will return the projector for inspection.

Maybe you can try a last troubleshooting :
Have you any other charger (like one for Mac Book Pro 15") and/or any other USB-C/USB-C cable ?
At least, yes, a return will be fine.

I only have an iPad Pro adapter (usb C to usb C), but that doesn’t appear to do anything (too low voltage I suppose).

And if you use your iPad Pro USB-C/USB-C cable with the PPM charger ?
It is very unlikely to work, but who knows…

I just tried, but it doesn’t make a difference. The projector receives power from the charger and the cable is working. It’s just that charging takes > 24 hrs, and then still it’s only half charged.

Well, the return ticket you received from Philips will be the last option…

One last thing that I noticed: after unplugging the charger cable (with the projector turned off), the RED status light keeps burning. See picture. The projector on this picture has been unplugged for > 1 hour, and still the RED light keeps burning. Looks like something’s wrong with the power manager inside the projector.

Your diagnosis seems correct to me. The charging chip might be faulty. Please file a support request by email! And don’t forget to paste the URL of this post for more info so they don’t ask you the same troubleshooting again.