Black screen from internal source

Hi, My projector projects a black image from internal source. It still shows the philips boot screen and it also work on hdmi input. Help!


Can you try to press and hold the power button for about 10 seconds once you have it on, to do a deep power cycle, and let us know the results?

I tried what you proposed and there was no effect on the issue. Same behavior. Tried it twice and waited before reopening just in case…

Sorry for the slow response btw… :flushed: i had to entertain the family since the projector didn’t work. :crazy_face:

HI Mathieu, please open a ticket with for guidance on how to fix this, perhaps a form of reset might work.

Ok thanks

I have the same problem, can someone help?

Please open a ticket with, mention the problems you’re facing and ask if the Cable restore procedure might help in your case. If they deem so they’ll share the link with you.

We do not post the instructions publicly as we don’t want people to resort to that too early in the diagnosis or solution tree. The support technician will walk you through the diagnosis and decides if it will be something to do in your case.

1 Like