Can't go back to Airplaying screen after pressing Home button

I often use PPM with my MacBook as I wanna Airplay my screen to have “dual monitors”. But I find a minor issue when I use this function. The steps are as follows:

  1. Airplay my screen from my Apple device (iPhone, iPad or MacBook)
  2. Press “Home” button as I wanna go to Setting to make color adjustment.

After Step 2, in fact there is no way for me to show the airplaying screen from PPM again, but in fact it is still mirroring since the audio is still playing on PPM.

And when I try to disconnect the mirroring and reconnect, I cannot make it again unless I restart my PPM.

Not sure does any one encounter the same issue??

I agree with you, we should find an item « AirPlay » in the list of Input sources, as we have Android, HDMI and USB-C.

But when I’ve tried your sequence with my iPad, I’ve been able to disconnect/reconnect AirPlay from it without restarting my PPM…

Have you tried the going back to Settings >> Mirroring >> iOS ?
But I agree, there should be a way to go back to it easily.

It really goes to the Setting part and cannot go back to my mirroring screen…

I’ve just tried again with my MacBook Air but I cannot re-select PPM to mirror my screen, unless I restart my PPM to make it happened…

@PhilipsEngineering would need you to advise on this issue.

I’ll test this out for you using my iOS devices, don’t have a Mac(book) to test it with though.

I tested this using iOS devices as promised and concur that once you press the home button you cannot get back to the video that was being mirrored or Airplayed.

But I believe this is the same behavior as with any Airplay receiver, even my Apple TV’s react this way: if I press any button on the remote I lose the video being Airplayed and have to start the transmission again by either de- and re-selecting the PPX620 device on the sender, or stopping the video playback and restarting it on the sender.

So I’m not sure that the dev team can change anything about this behavior as it’s working as intended / designed by Apple.

1 Like

@PhilipsIvo did you restart the apple tv during your steps ? if not should not ppm must be the same ? as what @Hoyo is saying

No, I did not have to restart the PPM to get the movie playing again after going to Home. All I did was deselect the PPM (Stop AirPlay mirroring on the sending device) and reselect the PPM (Start mirroring on the sending device again).

So my experience was unlike what @Hoyo described.

1 Like

Hi @Hoyo.

I think you have an issue in your Mac, because I’ve tested on my Macbook Air 13" 2019 (MBA) and it works as it should (as explained too by @PhilipsIvo above) :

  • I select my PPM on the Airplay menu.
  • My MBA screen is displayed on both its screen and PPM.
  • I press Home on the Airmote and I’m back to the launcher on PPM. The screen of my MBA still looks like it is connected in Airplay.
  • No mean in the PPM to go back to the Airplay mirroring screen. Settings/Mirroring/iOS shows options of IOS mirroring (these options need definitely further exploration, anyway).
  • On my MBA, I stop mirroring in the Airplay menu and reselect my PPM.
  • After few seconds, it shows on PPM again.

If you try these sequence, after stop mirroring in you Mac, is your PPM shown in the Airplay list of devices ?

3 Likes

Noted thanks for the update

If you can’t find any other iOS devices to test with take it to a place that sells iPhones or iPads, like the Apple store for instance, and test the airplay there.

Thanks all for helping me to verify this :blush:
I’ve just tried once again with my iPad mini and indeed it works fine.
It seems that’s really a problem on my MacBook per se.

2 Likes

Just to add a data point: I’ve had problems with my WiFi access point’s firmware causing AirPlay to stop working. In case you have a TP link router it could be due to this. Downgrading the AP’s firmware solved it

2 Likes

I can’t even connect via AirPlay screen mirroring, neither from iPhone 8Plus nor iPad 7. Both have the latest OS. Black screen on PPM, controls are visible. Progress bar on phone/ipad moves. No sound, no image on PPM though :frowning:

I had a similar situation when I tried chromecast desktop casting from my laptop. I had to go back home but no way to go back to the casting except it is actually possible by going to the app switcher :wink: Unfortunately, there’s no way to do it unless you have a keyboard or remote that can trigger the app switcher. I think PPM needs a way to trigger app switcher. Maybe once the settings UI becomes overlayed :slight_smile:

2 Likes

Hi @yhalmudt which app are you using? Sounds like DRM content.

Coming soon!

2 Likes

Yes, I guess that’s it – tried Sky Ticket, Disney+, Apple+ and Prime.

Managed to install Disney+ on the PPM, so that’s good.

How can I install Google Play Services though? When trying to install the streaming app of the Berlin Philharmonie, it says it was be supported by PPM but when opening the app it says “Google Play Services needed”.

Hi @yhalmudt due to licensing reasons we cannot legally offer Google Play Services, so at the moment we don’t have an official solution. There might be ‘community’ solutions.

2 Likes