Date/Time issues and how to correct them?

I updated my sw to 1.0.25 and the date shows correctly, but the time is 6 hours off.
How can I correct the time to my current time?

1 Like

Set the timezone correctly. It should automatically adjust the time for you.

Where do I set the timezone?
I cannot find it.

I cannot remember exactly. I think is from Settings > Language.

Got it. Thank you.

1 Like

You’re welcome. Glad it worked. :blush:

How to change the time and date??

Hi @Andrej_Mioc

You don’t really change date/time.
You connect your PPM at your WiFi network, you go to parameters and choose the right timezone and that’s it !

I’ve been getting a lot of use out of my PPM lately, roughly 8hrs per day while stuck in isolation in a remote location. So far, I’ve managed to find resolution or workarounds to most of the many software bugs.

The one bug I can’t seem to beat is the date and time. I have to manually set it 9 times out of 10, it defaults to Jan 21st 2016 and the auto update just never works. I have wifi connectivity, though it’s fairly basic it is enough to stream so should be good enough for the date and time.

I have been into the hidden Android menu and verified auto date and time update is on, but it never works.

Anyone else?

1 Like

I don’t know your tech level but I found this while searching for info on how Android does its time synchronization:


Perhaps the router’s firewall is blocking access to servers or protocols used? :man_shrugging:t4:

Perhaps @PhilipsEngineering can enlighten us on this and how it may affect your situation?

This bug has been reported by more than 1 person, so I will be discussing this with the team and update you. My guesses are one of the two:

  • either the NTP server is inaccessible, could be blocked port as @PhilipsIvo said, or could be just congestion. I will check which NTP server is burnt into the firmware.
  • the ntpdate daemon gets flushed out of memory due to heavy usage of other apps. This is not very likely as the projector has 2GB RAM and the daemon probably doesn’t use more than a few hundred KB.

I’ll get back to this thread once I have more info.

4 Likes

@PhilipsIvo, you may be on to something. Where I’m currently in isolation, the wifi we have been provided is very locked down and restrictive. I don’t have access to the router.

When I connected via hotspot from my phone, the time did update. Perhaps this is the culprit.

Edit: After more testing, I’m convinced this is the issue. It works reliably when connected to another network (phone hotspot).

It does bring me to wonder though, if I’m using it offline with downloaded or SD/USB content, then I’d have to update the clock for it to work properly. I read on another thread here Netflix and others will not play downloaded content properly if the clock is wrong.

Could it be as simple as having the PPM remember the time while in off/standby mode? There must be some mechanism to do this through a simple software update?

3 Likes

New user here, just unboxed mine yesterday and been having wifi connectivity issues. I have successfully connected to our home wifi but there is no connection. The time and date have been setup via the hidden android settings but it just reverts back to 2016. Thus, can’t really run most apps specially AptoidTV… Help!

Hi @rom is there any possibility to use a 5 GHz wifi network? The 2.4 ghz band shares the antenna and spectrum with Bluetooth and other networks in your neighbourhood, due to which it can be less stable.

2 Likes

I don’t think 5ghz is an option right now. Is there any other way? 2.4 band is quite common though…

Try the android wifi screen to forget and then re-connect to wifi.

Using this menu: How to access hidden (default) Android settings?

1 Like

tried it but still wifi is connected but no internet, wrong date and time so I can’t do anything with this machine as no app would work

Try tethering off a phone and see if the time updates. Also you should look at setting up 5ghz wifi as bluetooth is now taking up the 2.4 bandwidth. Another thing to try is a offline firmware update.
Time does my head in this day and age as it’s still widely used as a security standard for authentication!

1 Like

I have this problem occasionally too. Every time I have to wait for the Wi-Fi to update the date/time. Sometimes it is within seconds. Sometimes I have to wait for more than a minute.

I am puzzled why can’t the PPMax maintain the date/time since it has such a huge battery. Something like how phones/tablets can still maintain the internal clock even when switched off.

@PhilipsEngineering, is it possible to make the PPMax keep the internal clock running to maintain date/time when power is off?

Thanks.

1 Like

Okay, so what we managed to do in our place was reset our Orbi Mesh to factory settings. (it sucks to restart everything) but apparently the issue is now fixed. Not sure where it started or what have caused the time delay issue but it seems our router itself has some timezone issues as well… so if everything else fails, try a hard reset on your home router – or try another connection first just to be sure.

2 Likes