Device won't charge

M PicoPix was working great until it ran out of batteries. After I tried to charge it but the charging light won’t even go on. I tried a different USB-C cable and different wall sockets but it still wouldn’t charge.

Can you test the charger with some other device to see if it’s the charger or the projector that’s at fault?

Hi, I test the charger and it works with another usb c device

Hi @cjowjow.
Welcome to this forum.

Can you go thru this test protocol and answer each question ?

It will help @PhilipsNono to identify a faulty unit and to provide help, either to troubleshoot the issue or to organize a potential return.

Check battery charge status

  • Make sure the projector is powered OFF. yes

  • Connect the power adapter to the projector. Make sure you plug it into the right side USB-C port (charging port), not the left side (video port)! yes

  • Does the LED turn red? If yes, let it charge for 3 hours until the LED turns blue. Then unplug it, and power it on. Does it work? Does not turn red or any color

  • If the LED doesn’t light up at all, check that:

    • the adapter is receiving power from the wall socket. yes

    • do you have another USB-C device? Can the PicoPix adapter charge that device? If not, the adapter may be faulty. Tried with another USB -C

  • If the LED lights up blue, it means the battery is fully charged. Continue to next section. does not have any color

Check display problems

If your projector can turn on but doesn’t display any picture, check this as you power on the projector:

  • Do you see the white Philips logo startup screen? no

    • if yes, but there is no picture afterwards, check that all cables (HDMI / USB-C) are unplugged.

    • does pressing the home button on the remote or touchpad causes the home screen to appear?

    • does pressing the autofocus button on the remote show the focusing screen?

  • Does the projector power off shortly after showing the home screen? It could be a thermal shutdown. check next section.

Thermal shutdown

If you don’t see the Philips startup screen, or the projector powers off soon after starting up, check the following:

  • Do you hear the fan spinning up when you power on the projector? no

  • Do you have at least 30 cm free space on all sides of the projector to allow free movement of air? yes

  • What is the altitude of your city? (the atmosphere might be thin!) 659

  • What is the room temperature where you’re using the projector? 70F

I have exactly the same symptoms. Does your USB-C lead push in with a click? Mine doesn’t.

Mine does make a “click” sound when the USB-C goes inside

Thanks for the diagnostics. Please copy paste these steps when you contact support@screeneo.com to ask for a replacement for a defective device.

Hi Guys, received my Projector on Friday but I am unable to charge the projector, constantly flashes red and blue, have tried a different cable (doesn’t work) but currently do not have access to another USB C charger that will supply enough to test that, I have tried leaving the projector off to charge it over night last night and it doesn’t seem to do anything, any ideas ?

Can the supplier power adapter charge any of your other USB-C devices?

I have just checked it and it looks like it will charge my iPhone with a USB c to lightning cable but the actual charger seems to make a squealing sound, also when the projector is powered on and plugged in it shows as charging

And the image should become a bit brighter too.

So do you mean it is actually charging now? (it’ll take a few hours to charge when powered on). If yes, I suggest continuing to use it for a few days and report back to us whether the problem disappeared itself or not.

I ran it flat, and then it would charge to about 66% I assume (2 bars on the screen) and then it just stops charging and starts flashing Red/blue not sure if it’s a faulty charger or device now

Ok thanks for the info, let me check with the hardware team and get back to you, whether it’s hardware defect or something else.

Hi Prashant, It now will not charge the device at all if it is not plugged in i cannot use it any news?

I think it’s a faulty battery. Please submit a new ticket at support.screeneo.com or via email at support@screeneo.com for a replacement unit.

I have emailed Philip Support multiple times, even provided video of the charger not worker and I have not received a response. I follow up with a email every or ever other week and still get no response.

Same issue as Retroboy. Charges then just stops, haven’t been able to get it over 53% (first charge, it stopped charging despite being plugged in then ran flat). Adaptor works, registers as “fast charging” on my Samsung S9. Now tends to stop charging around 10%. Software is updated and I have checked all connections individually, and reset them. Aside from this, love the projector- please advise how to fix/or if as above it is a faulty battery am I cleared to get a replacement?

You said the charger works because of testing with a Samsung phone, that only requires power at 5V. The PPX OEM charger can provide 3A at 5V for a total of 15 watts. Providing the minimum of 3A at 15V for the PPX operation makes for a total of 45W minimum needed, which might cause the charger to overheat, underdeliver, or stop charging altogether if it’s faulty.

So I personally would not rule out the charger yet until you’ve managed to test with another USB-C charger that can deliver at least 3A at 15V. I would personally rather invest into testing with another charger before going through the whole replacement process.

IvoG
Thank you for such a rapid response, the only other USB-C charger I have is for the samsung and that does not work on the PPX - presumably falling short of the power requirements. It could be overheating, it does vary in when it stops charging. The adaptor is free standing and away from other sources of heat, aside from that I do not know what else would help. As you can tell I’m not an electrician, in the absence of a suitable 2nd test adaptor what is my next step? Would philips replace the charger to test?