Disney+ not working

Hi all,

Today Disney+ stopped working for me. It said there is an update available and when I try to update it opens Aptoide store but there I cannot find Disney+ anymore.

Tried to uninstall the app, restart the projector and search again in Aptoide store but at no luck. After uninstall I saw that I can use the Launcher to update the app but that version also is stating that there in update and tries to open Aptoide which fails to find any update for it.

I guess I will need to download the APK from somewhere else and install it.
Anyone else seeing the same problem?

Thanks
Mircea

1 Like

Not sure if that helps but if you go into the aptoide store, than go to settings than to preferences and clear the cache. For some reason Disney plus has a problem updating if you don’t clear the cache first.

Tried that, sorry, forgot to mention it. This time is different. Simply the app does not exist in the store anymore.

Same here.
This time clearing the cache didn’t help.
Any idea?

I’ve just installed different versions from APKPure.
All 2.x variants are starting but when I select a profile they crash.

Tried a few variants 1.x and they all start with a pop-up to update.

I’m stuck and Disney+ is a must have!

Any ideas are welcome.

This seems to be the latest version which works on my phone (Samsung Galaxy Note 10+) and on another Android TV box(Minix) connected to my TV.

Though on PPX it seems to crash.

Anyone else who have a working Disney+? What version?

Glad I’m not the only one trying to fix this, I uninstalled the app and now I can’t download it again. It’s very frustrating, I was hoping to have a movie night with the family but it only works if connect my computer with a hdmi to the projector.

I’ve emailed Disney+ that there’s something wrong with the app on android and I can’t find it when I search for it

Ok so I talked to the customer support and he said Philips should take a closer look at the issue since they only take care of the software from their end but the problem might be with the software in the projector.

So does anyone know how to get in touch with picopix support to try to fix this issue?

I spoke to customer support on Disney+ and the guy told me that Disney made a update last week, however he wasn’t sure if it affected the app disappearing on aptoide. He told me I have to get in touch with the people at Philips to take a closer look at this issue because it’s working on other platforms and OS.

How do we get in touch with Philips?

Philips/Screeneo did not change anything. At least not in my case since I have not updated the software or anything like that.
The issue is for sure in the Disney+ app and that what their support typically do, diverting the problem especially when we talk about a non supported hardware.
The most annoying thing is that the Disney+ app was working just fine and I would not have touched it if they would not forced the upgrade. Even going to previous versions does not seem to be an option since you will get the update pop-up on the older versions which might have still worked.
Tomorrow when I will have some time I will reach out to Disney+ as well and push them a bit.
Their choice to block the older versions while the new ones are crashing is not appreciated on my side. This made the subscription useless for me, I don’t want to watch their movies just on the TV it is much more important on the projector for kids.

1 Like

@PhilipsNono Any hints how to debug this?

Was gonna do a Stars Wars movie marathon this weekend, but now i’ll have to settle for Narcos Mexico season 3 on Netflix

Also the Disney+ app on my samsung tv isnt working either so its probably something on their end

Can you check what version you have in your Samsung TV?

I have a suspicion that they have blocked all 1.x versions. I had to upgrade my Minix Android TV as well to get it back working.

The instructions in this post worked for me to install a working Disney+ app (version 2.2.0-rc5):

The trickiest part was getting the zips onto the projector (since my projector is ceiling-mounted, so USB transfer isn’t really an option). In the end installing a true/newer version of Firefox (via Aptoide) which allows downloading files worked the easiest.

2 Likes

Just had the same problem. My solution was to install APKpure

Than when I clicked on update I pointed it to the apkpure app clicked on download than it asked me to uninstall the newer version first than it updated it with an older version of Disney+ which btw has also the download button.

Installing worked for me as well so I have the newest but it is crashing immediately after I select the profile.

Hello, we will push a new update today after testing.

1 Like

That is good news. Can you be a bit more specific about the update?
Is it the Disney+ app or the whole software?

If it helps I can offer my beta testing for it.

Hello, just the APK. we tested the latest version 1.17.1 but seems the message still appears. There are new BETA version 2.x but crashing… We continue the test, this may take more time as expected. We ay need to discuss with Diesney+.