Dropping into launcher permanently

Dear all,
my PPM shows strange behaviour: It drops into the launcher repeatingly. From any application, even the Setup/Configuration application, or Aptoide. Re-opening the application continues where it left off. Even when playing videos using Plex, re-opening the app continues playing the app. So it seems that something kicks the app into the background, without any reason.

I have the latest firmware 1.0.25, and have done a factory reset. Still, the same happens with any application I am trying to use.

Anyone else has seen this problem and knows about how to fix it?

Thanks

Have you tried removing the battery of you remote? just to eliminate the possibility that its home button is broken. Then also try wiping the touch controls in the unit itself. Maybe the home button there is also faulty.

Thanks for the idea, I have now removed the battery and cleaned the touch controls, it still happens. Any further ideas?

Ok, at this point based on your testing and several others, I am more and more convinced this is a software bug and not a hardware problem.

Please bear with me for a bit as I figure out the simplest way for you to do some additional testing that will let us know the root cause for sure.

I could approve a replacement but I think due to HK/China closure this will take at least 2-3 weeks to reach you. So might as well do some testing. In the meanwhile I hope you will be able to use it with the HDMI input till we fix this problem —> actually does this also happen with HDMI or USBC input? Or only when using internal apps?

Hi
thanks for your reply. Let us first test as much as possible, replacement can still be done afterwards if it is a hardware problem.

I haven’t tested HDMI by now, and don’t have any device that can send video data over USB-C, but I will try later today with my laptop.

I tried normal HDMI connection, and it works nicely, at least for the last 20min.

That says something because the home button also serves as a way to go back to android while using HDMI/type-c.

Yes indeed. I forgot to add that the remote is also connected, so it is neither the home button on the remote nor the one on the touchpad, but it sounds very much like a software issue.

Exactly. So it’s not due to any hardware issue activating the home button on the remote or touchpad.

Hi,
Just received mine and I have exactly the same problem as @norbert. I’ve proceeded several factory reset and removed the remote battery without success.
If I play content from an hdmi device or usb-c everything is ok. As soon as I try to play internal content it throws me to the home display. The only solution to play internal content is to keep a finger on the trackpad…
@PhilipsEngineering do you think you could find a solution ?

Yes, this issue is reported too many times now and is at the top of my list.

I am totally booked till Tuesday night but Wednesday I’ll be working on this issue. I think it is a bug in the launcher taking over, but not sure.

Thanks a lot. I‘ll use my fire tv.
By the way I’m quite happy with the quality of my ppm :).

1 Like