FAQ: How to pair the AirMote?

Some of the pre-installed apps (like Netflix) are tablet apps, so you must use it as if it was running on a tablet. There are two ways:

  1. Via the AirMote : After pairing (*see below) your AirMote to the PicoPix, you can press the mouse-pointer button on the top right to activate mouse mode. When using the AirMote, the OK button has no effect. Press the Mouse-Pointer button to “click” something on the screen. You can scroll by pressing and holding this button, then moving the remote (dragging gesture). Mouse mode can be deactivated by pressing any up/down/left/right key.
  2. Via the touchpad : Use two fingers to scroll the screen, and tap something to ‘click’ it.

In this way you’ll be able to navigate within apps that don’t respond well to the arrow/OK keys. Let us know if you still have difficulties.

How to pair the AirMote?

  1. Go to the Bluetooth settings on the projector
  2. Press and hold [OK] and [VOL-DOWN] on the remote till the LED starts to blink.
  3. Now choose " Scan for devices " on the projector. You can still use the remote during this.

The Philips AirMote should appear in the list. Select it and press [OK] to pair. If it doesn’t show up, try turning Bluetooth off and on on the projector and Scan for devices again.

The AirMote is really useful, for apps like Netflix, Hulu, Youtube, Amazon Prime

In an update very soon we will add EasySetup app which will take care of this for you. In the meantime we are sorry that you have to do the pairing manually!


This does not seem to work for me. After holding down OK + Vol-Down, I can’t see it on Scan for Devices. I definitely sure bluetooth works cause I manage to pair it with the speaker. But yes. If you can have a mobile app that can connect on same Wifi with the Projector that will be awesome. Cause right now who wants to use a manual remote. This is being done by Apple TV and the likes also.

There’s an EasySetup app which will do this pairing for you automatically. But it’s still incomplete, we expect the next software update will finally include it!

Now I got it to work only after updating to 1.0.25. For the rest maybe they can start to update to and it might work


Exploring PPM bluetooth ability i have accidentally removed the air mouse from the paired devices list :sweat:
I tryed to do the pairing again (first time was easy!) but the remote seems not be agree with me to start the pairing mode…can you tell me if there is a way to reboot the remote in order to be able to do the pairing?
Thanks !!!

You just need to press and hold OK and volume down button till the LED on the remote starts blinking. Then, click “Scan for devices”, the remote should show up as the first name on the list.

Don’t ask me why but worked with ok and arrow :laughing:…but thanks!

Got this to work, thanks

1 Like

Mi airmote is paired, but the arrow disappeared, and doesn’t come back pressing the arrow button.
What may I do?

You need to unpair and pair it again. I’ve also had this happen to me once.

1 Like

Thanks, It worked

1 Like

Any update on when the EasySetup app will be released?

1 Like

I’ve tried all the above suggestions, including cycling the PicoMax on/off and replacing the AirMote batteries. Other devices easily pair with the PicoMax via bluetooth, but the AirMote will not even show on the available list. Frustrating.

Try and switch off all other bluetooth devices in your vicinity and see if that helps, it took me a few goes the 1st time as well, the projector seem to be sensitive with interference , not guaranteed to help but worth a try to eliminate all factors

1 Like

I switched off other bluetooth devices. The AirMote still did not appear. I tried rebooting. That made things worse. Bluetooth was turned off and the error message “The bluetooth adapter is not turned on!” was displayed. (see screenshot)

Switching On the bluetooth didn’t change anything. The screen shows the same as in the screenshot, only with the switch in the On position. Whereas before I had a list of 3 bluetooth devices showing as connected and 3 more available, now there is no list at all.

Rebooting again didn’t help. I’m running the latest software version. Could this be an issue with the Pico’s bluetooth hardware?

Hi @RitzMan please follow every step of this guide exactly as described:

It should show up in the list then. It’s important that the LED on the remote is blinking, and that you click “Scan for devices” on the projector.

This suggestion didn’t work. I did a factory reset and that did the trick.

Hello. I followed the steps, however “pairing…”
message disappear and the remote stays unpaired and unconnected.

Have you ever been able to connect it once, or is it at you r first attempt ?
I had to switch off/on bluetooth on PPM to find again the airmote.

1 Like

Thanks! Switching Bluetooth off and on did the trick.