Few questions for first time start up

So excited that my PPM arrived today! However, I have encountered several problems.

  1. with miracast, which it is not working (nor is connecting my Surface Laptop 3 to the PPM via usb c cable on both ends). The message “something went wrong, could not connect” keep showing up. I have read through all other posts regarding this issue, and have tried every way to solve it, still no luck. So maybe can I please be enlightened on how to resolve this issue?

  2. when i start the ppm for the first time, it went straight to the home page, but not the language/time/date set up page as stated on the set up guide, does that mean i got a second hand device?

  3. everything on it is default to be chinese/ china. I download chrome, it gives me Simplified Chinese google site/ on youtube all videos suggestion is based on China (which i have not yet signed in), how can i change this?
    @PhilipsEngineering @PhilipsSupport please help, thanks.

1 Like

and btw excellent job of delivering the PPM within 2 days upon my reception of the tracking number! @PhilipsNono thanks!!!

  1. Please repost this question in one of the threads dealing with either Miracast (for the Miracast issue) and / or USB-C video (for the ISB-C video issue)

  2. The Easy setup app wasn’t finished yet / had some bugs, which is why it isn’t included by default in the firmware yet. So yours is not secondhand or refurbished in any way.

  3. Try https://www.google.com/ncr for No Country Redirection.

1 Like

Have you gone into Settings > Language to set the region and language? Maybe that will solve the default language issue.