First time set up blurry projection

I finally received my Pico Max after 5 months of ordering. Charged and eager to get started, I switch it on and I get a blurry screen so I cannot set it up. We pointed the remote to the projector to focus and nothing happens. So what now? Can I get it replaced and if so what process to follow assuming I do not need to wait another 5 months. This is really frustrating and disappointing.

1 Like
  1. Have you tried this again afterwards, or only this once?
  2. Do you hear any focusing when you move it a bit while on?
  3. Have you tried to physically bring it closer to the wall / screen, until it is in focus?
  4. You pointed the remote to the rear of the projector and pressed the focus button, do you hear any mechanical sounds at this point?

I had this issue when setting it up at the start. My workaround was placing the projector extremely close to the wall in a straight manner and slowly moving backwards until i get clear image from the autofocus

Another user this was suggested to reported that it did fix his unit’s focus issues.