FRUSTRATED: Dead PicoPix Max

I’ve been attempting to contact support for three weeks with NO response. Seriously, what do I need to do? I reported everything as asked. I’ve been patient.

I received my picopix right after Christmas. It died one hour into a Netflix steam (powered off, won’t power back on). I contacted bugreport email with the details. They said they would get back to me soon with test procedures. Have heard nothing back. Have sent several other requests including full details & serial number. Still no communication. What should I do?

Maybe the test procedures could be detailed in this forum @PhilipsEngineering?

I think it would make sense to have all the failures listed in categories. There have been a few reports of “dead” PPMs, some with red/blue LED flashes, some unknown. Maybe these are all the same issue, maybe not. If the fault is known then I think it should also be stated whether it’s something that will require a replacement or if there’s an immediate solution (if there are such cases apart from the remote pairing issue).

2 Likes

HELLO??? Will someone from Philips please respond and advise how I should proceed?

Hi, me again, device still dead, 3 more days since I posted here three weeks since initially reporting) still no response from support. How should I proceed?

Hi @thean sorry that you didn’t yet get a response.

Can you please follow the test procedure here: Troubleshooting: Projector won’t power on / no picture display / shuts down soon after starting

and let us know your findings?

Followed what was outlined. When the device is plugged in with included power supply, there is a green LED.

Pressing power button does nothing. Holding power button (tried up to 30 seconds) does nothing.

My bad, wrong port, LED is red.

Hey, just saw that they gave a detailed troubleshooting guide here. Can you please try the steps.

Thanks,