I think my focus is broken - fixed!

My projector arrived today; focus does not seem to work under any circumstances. Neither autofocus nor attempts to manually focus seem to have any effect. The picture only appears in focus at about 50 cm in front of the projector.

I’ve tried updating the system software; no change. Anything else I should try before requesting a repair or replacement? Any way to know for sure if I’ve been affected by a hardware issue?

I live in Canada – I don’t have a lot of experience with international returns; I’m somewhat concerned that I will be charged again for import duties etc. If there is any alternative, I’d like to know.

Hi @ZacT

I suspect you got a defective unit, though as a possible quick workaround may I suggest you to turn the projector towards the floor and activate the autofocus 15 times, then point it to the ceiling and activate it 15 more times. Some fresh-out-of-factory units need this to properly activate the free motion. If that doesn’t help, it might be defective.

In any case could you please email support@screeneo.com, or use the “Contact” link on the top right of this webpage to create a new ticket. This lets our helpdesk handle your request centrally.


is there any plastic protection film over the camera lens that maybe blocks the view ?

1 Like

Amazing info Prashant; that seems to have done the trick! After targeting the floor a large number of times, it was starting to show change when I tried it on the ceiling 15 times or so (before that, there would never be a detectable effect on the picture), and then I restarted the device and it now appears to have full free motion. Thanks again.


(There was never any film over the camera on my device. And even manual changes with the remote had no effect on the focus depth. But it’s a good thought – I can imagine something accidentally leaving the factory that way)

1 Like


:partying_face: :tada: :film_projector: