In Portugal, anyone suceeded in streaming the NOS app?

Hey guys,

I know that there are other Portuguese backers, so maybe anyone can share their experience. I’ve tried the NOS tv app in Aptoide but after login I get an error and thats the end of it… is it just me?

I would kindly like to ask anyone reporting an issue or succes with getting an app to work on the PPM, to include at least the following information in bold , if not all of the following:

Service: (what does it do, what is it for)
App Name: (name fo app)
App Version: (version number of app)
Source: (Aptoide Store, web page with URL, etc.)
Status : Working fully / partly / not at all (elaborate in notes if needed)
PPM Firmware version : a.b.c
Full HD: Yes or No
Remote Support: (Works with Standard remote, or tablet / mouse interface)
Notes: anything worth noting about the app, Settings, install procedure.

Could you do that for this case also please?

Still waiting for mine but that will probably be related to the missing play services it’s just a mess…

Hello Ivo,

I am going to have to apologise here but that is a bit more information that what I can gather… Its not that I am not fluent with technology, it’s just that most of that I really don’t know even where to find it. Nevertheless the problem is solved and I will try to explain it in the simplest way I can. See if it works.

  1. Via aptoid I installed the app for - cable tv supplier in Portugal, which also has an app that allows you to watch tv online
  2. When opening the app, it requires a login into your account (basically so it know what kind of content it will show you (e.g. paid sporsts channels)
    3.However the login does not occur on the app itself, it was opening Firefox in NOS client website.
  3. The login was not complete as an error message would appear regarding a given protocol that was not working.
  4. I got back to aptoide and installed Google Chrome
  5. Went to NOStv website via Chorme and loged in to my account, which worked great.
  6. Navigated the website to get to the page where I would be redirected to the app it opened and I am now streaming to the Pico Pix Max.

I am sure that there was some more IT wizzardry in the background but that is how it worked for me.
Sorry once again for not getting to the specifics as requested but this is really the best I can do.


PS. Your doing a great fu"#$ job as a moderator. Don’t let the haters get to you!


Hey Hugo,

Got it solved. Works fine now!

First of all, thanks for the kind words, much appreciated! :blush:

Getting this information doesn’t require fluency with technology really, just a little guidance perhaps.

If you go to any app on your home screen, you can open the context menu for it by pressing the button rightmost of the Home button (the one with ≡ on it). In the image below I’ve done so for the app Aptoide TV, which then shows the version number on the Context menu

So in this example (combining the info you gave me on yours just for illustration) you’d fill this in for your original help request:

Service: watching TV online via cable TV supplier in Portugal
App Name:
App Version: 1.4.0 build 202625
Source: Aptoide Store
Status : Unable to log in, login page opens up in Firefox and fails
PPM Firmware version : 1.1.0
Full HD: Not applicable
Remote Support: Unknown
Notes: The login was not complete as an error message would appear regarding a given protocol that was not working.

After successful log in you could change the Status and other fields that lead to a working situation.

So basically you have fixed the issue with the app’s login by login in via Chrome instead, all of this on the PPM itself?

Side note: reason I asked for this specific info is because in The Netherlands we also have a public broadcasting organisation called NOS, which according to me wouldn’t show videos in Portugal either, so it wasn’t clear to me what you were talking about.

Hello Ivo,

Yes using Chrome solved the issue. All working top shape now.
And is I am referring to the Portuguese tv broadcaster!


1 Like