Initial setup/nothing is projected

Just got mine today. Powered it up, LED turned blue, fan turned on (noisily), but nothing’s getting projected. Am i missing something from the initial setup? I feel stupid. :smile: thanks

:anguished:

Do you at least see the Philips boot up logo?

What happens if you power it off, wait a moment, and plug the charger? Does the LED turn red?

Nothing, not even a blank screen. Basically bulb doesnt even turn on.

After powering down, LED goes off, fan quiets down.

When plugged in to power, LED turns red. Tried to turn on again, fan buzzez, LED remains red, bulb still dead. :frowning:

1 Like

I face the same problem as Ddscrz, turned it (not plugged in) - LED turns blue and fan is noisy.
When plugged in, the LED is red, fan is the same. No projection at all in both cases.
Tried to connect it to our switch via a HDMI but nothing comes out as well… The bulb does not turn on.

1 Like

@Ddscrz @Gravitationer

Let’s rule out a defective battery first. Could you both please turn off the projector and charge it (red led) until the battery is 100% full (blue led).

Once it’s full, please unplug the adapter and turn the projector on.

Still no picture?

Hello @PhilipsEngineering

As instructed, I charged til LED changed from red to blue, unplugged the adapter, powered up the unit, but still the same. Fan turned on, but bulb remained off.

Please advise how can I get a working replacement unit if not a full refund. I am based in Singapore. Thank you.

Ok, sounds bad, it’s most likely the LED or OE is defective. :frowning_face: We’ll need to exchange it.

Please email bugreport@screeneo.com and tell them you need a replacement unit due to this problem. They’ll send you a form to fill with info like serial number and your backer Id.

But a heads up: the Logistics team is still working out the return procedure for each region, so it’ll be a few days before you’ll receive instructions how to return it to us. The actual exchange should be fast though.

4 Likes

Hello @PhilipsEngineering

I got the following reply after reporting the issue:
|### Philips Projection|12:46 PM (5 minutes ago)||

to me

|

We’re sorry, but your email message to [“bugreport@screeneo.com”, “hello@picopix.com”] (titled [Philips Projection] PicoPix Max Replacement Request) didn’t work.

None of the destination email addresses are recognized, or the Message-ID header in the email has been modified. Please make sure that you are sending to the correct email address provided by staff.

Can you advise, or help me forward the email? I CC’d screeneo@discoursemail.com

Thank you

this all sounds bad, i guess i am hearing issues that were never heard before for the other who has received the units, @PhilipsEngineering can we please make sure this is dealt with internally before the new production line begins on 8th Feb, after CNY ?

i guess its not just for me but for all backers to make sure they get a unit in working condition and not be replaced .

who will absorb the replacement delivery charges and ant other misc. costs attached to it ? customer or Philips ?

this all sounds bad, i guess i am hearing issues that were never heard before

Hello Palak, if you’re not familiar with consumer electronics market it might sound alarming. But this is not only par-for-the-course, but actually a much lower defective rate than normal. You won’t hear from the silent majority of customers who have received a perfectly working product. We’ve shipped thousands of them.

So please don’t be alarmed, just because we have an open forum where customers can discuss issues doesn’t mean there’s a widespread problem.

5 Likes

Palak, what about if you press Home or Focus key, do you see a UI coming?

@Ddscrz I checked this; seems there was a config change on the server, they’ve fixed it now. Could you please resend the email? Sorry for the inconvenience.

@PhilipsNono

Tried everything. Nothing worked.

@PhilipsEngineering

Thanks. I already resent the mail, but i did not receive any automated reply as acknowledgment.

I still believe in the product and i hope this will be sorted out soon.

Thanks, we recovered your email.

Hello @PhilipsEngineering,

Yup, Did that as well. Charged it until the LED turned blue, unplugged the adapter and tried to turn it on again. No image. bulb doesn’t turn on.

Have already sent an email to bugreport@screeneo.com. Still awaiting their reply.

Thanks!

Ok, it could be a defective LED/optical engine. Tech support will get back to you.
Meanwhile if you have some time to troubleshoot more, I’ve just created Troubleshooting: Projector won’t power on / no picture display / shuts down soon after starting which you can follow and let us know your findings. Sorry for the inconvenience.

Hello Prashant,

Wow thanks for the speedy reply! Just checked out the Troubleshooting guide and can confirm that the Power adapter, USB cables and battery are functioning just fine.Even tried to charge my phone using the PicoPix’s battery and it was able to do so.

Do not see anything whatsoever upon starting up and also after pressing the various buttons. Fan is running and can definitely feel the airflow while it is on. Does not power off unexpectedly. Currently running it in an air-conditioned environment @ 24°C.

hey, a bit of an off-topic, but if you send e-mails through Chrome/Brave, there is an extension called Streak, which if you allow, basically notifies you when someone opens your e-mail with location and device. Quite useful if you have doubts :wink:

Sorry for the off-topic.

Exactly the same defect in here, I got it today from DHL delivery.
When turned on, it sounds noise and blue light but bulb remained off.

Sorry to hear that you have the same issue. I think you can find more info for returning and replacing the product on this thread: Click