Internet problems

Since this evening i have problems wint WiFi connection. In the settingspage my WiFi works perfect, but on the homepage and apps it dont work…

Have you tried the Firefox app ?
Is your PPM at the right date (a it retrieves this info from internet) ?

I have tried Firefox app, but it cant make connection…

The time and date are also stil wrong…

Wifi is connected normaly, my other devices dont have problems!


For troubleshooting your issue, I suggest you to test by tethering with a smartphone (share connection).
If it works, you will have to seach on your internet home chain side (box, switch, etc…).
If it doesn’t works, you will have to search on the PPM side.

1 Like

Try connecting to your wifi via the Android menu.
Go to Settings >> About and click on the Software version repeatedly until a menu appears on the right side. Perhaps you are encountering a bug in Philips’ own settings UI.

I have tried both; nothing works. When i try via the Android menu, the system says also that the ppm is connected to WiFi.

Today after a powernap I started the ppm; same problem, but after 15 minutes the system had found the WiFi. So I dont know how, but for me its solved for now…

I see. That’s good to know.
Probably something weird in your Wifi network. If it happens again, maybe try to connect on other networks like for example a mobile hotspot.

I have tried on hotspot, same thing happends;

I see its connected, but the apps, the time, the date, dont work… very very strange

Mine seems to take a few minutes to connect to the WiFi after I turn the PPM on. If I go into apps that need network straight away they all complain about no network, but then after a short while they start working again.

1 Like

I have the same issue and cannot see any resolutions on the forum. Any one has any ideas?

I’ve had this issue too. Ended up factory resetting to fix it.

I’ve noticed Netflix will get stuck on loading when watching via battery, very annoying. Not sure if it’s Netflix specific or general wifi issue.

I’ve changed the name (SSID) of my 5GHz WiFi to be different to the 2.4GHz, then told the projector to forget the 2.4GHz and connected it to the 5GHz instead. I mainly use mine via the HDMI input though so it’s too early to tell if the WiFi changes have made any difference.
This was suggested in a similar topic on this forum.

1 Like

robincm thank you for your response. Initially I tried the suggested actions but it did not fix the problem. I finally figured it out and connected to another 5G network with a repeater that is physically closer to the PPM. I did not think of that as the original WIFI showed full bars but at the end I think it was a weaker signal and PPM struggled with it.

1 Like