Lamp not working on startup - workaround

I reported this issue earlier, on the Dead on Arrival post

As I noticed a common theme of other customers reporting issues with the lamp not lighting up when you power up the unit. Philips Engineering were commenting that this may be due a short internal cable affecting 0.5% of units.

This may be the case but I think I have found a workaround which has worked for me. For a brief demonstration I have made my first YouTube video to demonstrate this workaround.
(Please like, share video… :grinning: )

To save you watching my basic video efforts, you can try and switch on unit using power supply plugged in and a few seconds later during startup phase, unplug the lead so unit is running off battery instead.

This has worked for me for last few days. When I leave the unit switched off, unplugged etc the fault returns and the same workaround has worked for me thus far.

For others users who may experience this fault I hope this works as a workaround until Philips can ship a replacement unit which may take some time.

Will be contacting support to raise return process later today.

Hope this is helpful to others.



Hello @Telboy thanks a lot of informing fellow users of this workaround.

However we want to reassure anyone who has this problem, that this is covered under warranty and we will replace the faulty unit free of cost. Because of the pandemic the replacement lead time is almost 1 month at present, but we are working hard to reduce it to 1 week or less.



Thanks for this advice but it is not working for me. I received my ppm this morning and just like you, there is no lamp.
I open a case to support #20915

To add to what @Philips_Support_P said:

Even if you can use the workaround, do make a support call to log the issue, even if you’re not ready to return it just yet. Logging the issue as soon as possible will make sure there’s a record of when exactly the issue appeared, in this case Sick On Arrival.

1 Like

how and where are we able to file such an support/return ticket?

Hi, I assume we need to first send an email to and report issue. They may send us a Return Form to complete.

Yes, that’s the correct way to handle it. If you have already done the troubleshooting according to the instructions here, please also report the results of that in the email you send. It will help to make the whole process smoother.

Hi, it appears the workaround is no longer working for me… I managed to re-start the PPM using this earlier fix and upgraded firmware to v1.1.01 (I think). Not sure if this revision of firmware has negated the workaround.

Have raised a support ticket & troubleshooting questionnaire to support this issue.
Support Ticket #21750

1 Like

@Philips_Support_P I had a similar issue and submitted a request for a replacement and it’s been over 2 weeks and I still have not received an update. Can I get an update on when I can expect to ship it back or have it picked up? I already submitted the google form.

Support Ticker #29979

cc: @Philips_Support_1