Mouse pointer not working


My mouse pointor stop working. I try with infrared and bluetooth and same result.

I made the test pointing the remote to the cam of the phone and all buttons work fine (I can see the light in tne camera) except the pointer.

I supose I need replacement for the Airmote. Can you send one?


The mouse pointer exclusively works with Bluetooth, not infrared. The fact that you see a light when you press buttons and use a phone camera means the remote is working.
It may be the case that the remote just needs to be paired again, please try that first.

Hi, All works perfectly, except the pointer button does’nt work (and don’t have light in phone camera). I’ve tried all possibilities

Libre de virus.

Missatge de Ivo Grijt via Philips Projection <> del dia dl., 4 de gen. 2021 a les 16:29:

Same problem, i tried unpairing and pairing, the remote works fine, the light flashes when i press the arrow button, but the cursor doesn’t show up on the screen.

If i use the touch pad then its fine, but its VERY inconvenient. What should i do?

also even though i changed batteries, the cursor still wouldn’t show, OTHER functions work fine, but i also noticed that it seems that i have to hold the remote closer for it to register a reaction…

Hi, we need replacement of Airmote. How can we do this?

1 Like

Hello there. The remote works but, when I try to look for the device. It isn’t visible. The projector can’t find it. The Bluetooth is not working (I think). Can I get a new one?

I’ve got the same issue after the recent updates. My on-screen cursor didn’t appear at first, and later it appeared but the movement is very jerky. I tried changing the battery, but it’s the same. Wondering if the recent updates messed up the device.