Multiple problems with remote

I started having problems with my remote a couple of days ago when it wouldn’t work even though it was paired and I could see the red light when I pressed buttons. I tried replacing the batteries and turning off and on the projector with no change.

I then unpaired the remote with the intention to pair it up again but now the remote does not appear at all in bluetooth settings after scanning etc. I have tried this many times, turning off/on the projector and removing and replacing the batteries. No luck.

I have also tried scanning for the remote’s bluetooth signal via my phone and laptop and it does not appear.

Otherwise the remote continues to function in its basic way if I point (via infra red?) at the rear of the projector.

Any ideas welcome.

Have you tried it that way?

How to pair the AirMote?

  1. Go to the Bluetooth settings on the projector
  2. Press and hold [OK] and [VOL-DOWN] on the remote till the LED starts to blink.
  3. Now choose " Scan for devices " on the projector. You can still use the remote during this.

Yes, that is the method I used

I have emailed 3 TIMES over four weeks now and no response whatsoever.
This is completely ridiculous.
What does it take to get a response?


Does the pairing mode works on the remote? When you press OK + Vol- at the same time for 5 sec, can you see the red led blinking on the remote ?

Yes I can see the red light blinking but it does not pair

Hi @jarla try this:

  1. Go to Bluetooth settings and select the Philips AirMote (press OK), then from the menu on the right, select Unpair.
  2. Turn bluetooth off.
  3. Turn bluetooth on; the remote should no longer be listed.
  4. Now, press and hold OK and VOL– keys till the LED on the remote starts to blink.
  5. When it starts to blink, only then go to the Scan for Devices option and press OK.
  6. The AirMote will now appear again in the list, go to it and press OK. It should say Pairing → Paired → Connecting → Connected.

When it says Connected, congratulations it should work. But if the LED on the remote flashes everytime a key is pressed then it is still in infrared mode, and not paired. In this case please try the above process again.

Thank you for your email.
However this is now superseded as my project lamp has stopped working.

The ticket ID fr this is 31685.

Please chase this as I have had no further response from them