Netflix App doesn't work

I tried to update Netflix app with Aptoide and it didnt work so I uninstalled and reinstalled it, but now the app doesn’t work at all. It say this device isn’t supported for Netflix. How can I get a working Netflix app again?

Hi @Maximilian,
Welcome to this forum.

In order to go back to the pre-installed version, you have to uninstall it from main screen (by pressing the three-lines button in remote), and normally you’ll see this app back in this main screen.
Don’t try to reinstall it from Aptoide.


Same here.
Updated the firmware and updated the netflix ap on apptoide. It says the app is not supported on this device. I followed your instructions but the app still doesnt work.
The app is visible in the home sfcreen but with a “package” icon in the left corner.
I click on it and nothing happens.

Please, help!

Had the same issue. Just do a factory reset and all apps are back to the supported versions. Then simply do not update Netflix and MX Player…

1 Like

Did the same and worked. Learned my lesson the hard way :slight_smile:
Thank you