Netflix has stopped working

Philips team,
my Netflix app has suddenly stopped working. it keeps giving the error message “Sorry, we could not reach the Netflix service. Please try again later. (-80)”
i have tried everything, done a factory reset, tried to side load other versions but to no avail.
can you please advise a fix for this?

rgds,
Meghal

BTW this happened after i did a software update to 1.3

Hello, did you update your Netflix version ?

no i just installed from the app placeholder ( version shows 4.16.3 build 15172)

@Philips_Support_P could you check ?

Hi @Meghal we’re on it. Expect an update asap.

1 Like

Hello,
I have acquired a brand new PicoPix Max yesterday and I can’t get Netflix to work.
I have updated the firmware to 1.3 (latest version available), I have tried many things found on the forum (reset, factory reset, etc).
I’m with the default Netflix version and I did not the update.
I can log in but when I select my netflix profile, I get the following error “sorry we could not reach the netflix service (-80)”
Other apps such as Disney+ or Prime video work just fine.

Thank you very much in advance for your help.

Best regards,
Maxime

Hello, we have the same issue here, we are testing and checking if the issue is coming from Netflix or our projector.

Thank you for your feedback.
I hope you will be able to come back quickly with a positive update, otherwise I will have to return it :(, watching netflix being one of the main usage I foresee.

By the way, being new, do you have a thread or tutorial with tips and practical advices to adjust the keystone perfectly? I realized that autokeystone does not really work on my wall maybe because the projector is lower and projecting “upward” and I’m therefore using the manual keystone but I’m not sure to do it really well. Thank you in advance for your advice.

Hello Fraga, we understand that this is a concern but that does not prevent to use the projector itself. The other solution would be to connect a Dongle like Amazon Fire Stick or Roku or Google, or even a laptop.
In any case, we are on it!

1 Like

I have the same issue. Glad you’re on it!

We know this is important ! It seems this is impacting ALL projector worldwide using Android AOSP. We are digging.

1 Like

Hello all, it seems this was an issue on Netflix’s side. The issue is resolved and the app is working again as before.

4 Likes

As this problem with "cannot connect to the netflix service " did occur again and I couldn’t resolve it by clearing the app-data I tried installing two other versions via aptoide which do not work either. Question: Is there meanwhile any working version that can be installed other than the default version? Or is there any possibility to reinstall the default version without having to do a factory reset?

Hi,

I’m having trouble connecting to Netflix. Basically the error message is that password is incorrect, even though that obviously is not the case. I’m able to connect to the Netflix account on many other devices (at least 3 phones, a tablet and a Android TV box). Tried even changing the password but still getting the same error.

Last thing I’ve tried is deleting Netflix and installing it again from Aptoide. I know that is not ok but since it was not working anyway I thought about giving it a try anyway.
Still does not work, same incorrect password problem.

Anyone any ideas?

Thank you

Still could not figure it out. Anyone any hints?