Netflix not able to work if VPN is on

Hey guys I’m not sure if you’ve noticed this but after the update of Netflix I am having issues watching anything if the VPN happens to be on. Is there a fix around it? Netflix gives the error that it detects a proxy and directs you to the website netflix.com/proxy

@PhilipsEngineering

Doesn’t that work exactly as Netflix intended though? They have worked towards identifying as many VPN endpoints as possible. I just wonder if this is an unlucky coincidence?

Unlucky coincidence I believe. I’ve been using ExpressVPN for years, last week Netflix managed to detect it. ExpressVPN normally get around it again in a few weeks. Nothing to do with PPM

2 Likes

Didn’t realize at the beginning that I was getting trolled. Lol.

Getting trolled by Netflix. :slight_smile: And no I definitely do not work for them

Our friends over at ExpressVPN seems to have fixed it already and a beta will be uploaded to beta lounge tomorrow.

1 Like

So when are we getting our free 1 year of Express VPN?!?! :wink::wink::heart_eyes:

@PhilipsNono is the right person for that!

2 Likes

Any updates to rectify the issue with netflix?

1 Like

Hi @biohazard31

As already stated in this thread, this has nothing to do with PPM or Screeneo Team.
It’s the standard behavior of Netflix to kill access from all detected VPNs (due to copyright legislation).
If one or the other VPN providers can still offer an option/workaround, that’s outside the PPM/Screeneo’s responsibility.

Even on the Plex app, I can’t play any content.

1 Like

@PhilipsNono any update buddy?

That wasn’t the point of posting this. Netflix also blocked expressvpn but the PPM team was able to speak to them and they came out with the work around.

Now that we know that Plex and Netflix have the same issue it doesn’t hurt to just check and see if a possible solution can be found.

Any updates on this @PhilipsEngineering @PhilipsNono

1 Like

I haven’t heard about an update yet on this.

Unlimited VPN (keep solid) doesn’t work with Netflix on my PPM. This VPN service does work with Netflix on my phone, tablet, and computer.

Anyone have any ideas on what’s going on?

Also, I’m not able to chromecast Netflix to my PPM. Other apps are able to chromecast, just not Netflix.

What’s the deal??

Thanks in advance!

1 Like

Hello! I can’t find Express VPN anymore on the built in app store. Is there a reason for this and how can this be resolved? Thank you!

Hi @Ira Casas if you accidentally uninstalled the Philips-version of ExpressVPN, just restart your projector, it should come back. If it doesn’t, please install it yourself as follows:

1 Like