Netflix unable to play content with E VPN

Hi,

I tried using the Express VPN app that comes with PPM.
Whenever I activated the vpn, Netflix unable to play content.
Any workaround with this issue?
Or am I doing something wrong?

Thank you!

Hey, although I don’t have the ppm yet, I’ve used netflix on xgimi h1 before it was allowed in my country through VPN.

The problem is that Netflix keeps blocking VPN IPs.

Can you change the server you are using through the VPN? Sometimes this works and even the VPN provider switches IPs from time to time, so it might not work today, but work tomorrow.

What is the message you receive when you start Netflix while using the VPN?

I will give it a try later.
Thank you!

1 Like

Hello,
We will check with Express VPN to see if Netflix blocked their servers.
You can also use the DNS from Express VPN directly inside the Wifi option of the projector

are you connected through a 4G network or broadband connection?

Broadband

Seems there is an issue with the Express VPN app. They are checking. COuld you also test with the DNS of Express VPN?

Express VPN with Netflix on my smartphone is working.
On my PPM, I’m still having the message(image posted above) and not be able to play any content.

Hi!

Any updates on the VPN issue with Netflix?

1 Like

I have tried to chat with express vpn. They give me instructions on how to work around it but to no avail, it still cannot play the video when connected to express vpn. Hopefully, the pico team can update the built in app of netflix. Hulu so far has no issue. :slight_smile:

Same issue. I’ve tried multiple servers in multiple countries, and all I get is “could not reach the Netflix service.” Those same servers work on my iPad, and disabling VPN works on PPM (surprisingly, as I am overseas and would expect to be blocked without a VPN)

Hi,

Same issue here, Netflix via ExpressVPN doesn’t work on ppm. I have no issue on my laptop or smartphone.
I don’t have this issue with disney+.
Is there a workaround by any chance ? @PhilipsEngineering @PhilipsNono

Cheers!

Any updates on this @PhilipsNono @PhilipsEngineering? Am facing the same issue as well.

Netflix is clearly blocking more and more VPN’s. If they see users from somewhere else in the world in the US often and intermittently, they’ll start flagging the US IP addresses used until they feel it’s a VPN exit point, and then they block it.

I used to use NordVPN with Netflix also and it just stopped working at some point due to this.

I’m afraid there’s little we as Philips Projection can do. Have you checked with ExpressVPN what they say are ways to circumvent the issue?

Working with them to troubleshoot the issue, will update here if anything works. I did try using ExpressVPN on my phone and it works for Netflix. Not sure why it doesn’t work on PPM.

I was told to change the protocol setting to TCP, use ‘USA - LA 1’ server, sign out and sign back in on Netflix, and it worked for me. Let me know if it works for others as well.

3 Likes

this works! fantastic!

1 Like

That’s a great tip. What works flawlessly for me is if you go to Express VPN’s website (on a desktop) and go to the section for Smart TVs they have something called Media Streamer DNS. Once you set that up, any device you set up to use those DNS server addresses works flawlessly. Personally tested with Netflix on my previous projector, my Samsung 4K smart TV and my MacBook.

3 Likes

USA - LA 1 used to work for me up until last week. However, now no ExpressVPN server seems to work with Netflix. Already spoke with EVPN tech support and they suggested LA3, NJ3 and DC but none of those worked either on PPM although these servers are fine on iOS devices.
Are there any alternate servers that work for others?

Hi, without E VPN Netflix works fine. Connected to E VPN I get the same issues as described above (12001). I tried multiple servers in US, Canada and Europe but none work even though they work splendid on my desktop. I tried with protocol setting to TCP and every time signed in and out of netflix as well as doing a reboot.

Since it’s working on my PC it seems that it is indeed an issue with the PPM. Any news on a workaround? @PhilipsIvo @PhilipsEngineering

Thanks!

1 Like