Netflix version number after update v10.0.25?

Hi guys.
Can anybody please check? I ran into a problem while updating the app and now I’m not sure if it updated at all. Just check yours and let me know.


@dax01, from what I read in Update 18 announcement, the Netflix app is already in the correct version when you update the firmware to v1.0.25.

You are not supposed to update it, according to the patch notes.

Uninstall it and you’ll get a placeholder icon that you can use to install the PPM specific version again.

This Netflix issue does need to be addressed though. I am happy that the “patched” version supplied by Screeneo / Phillips works as it should, but the prompt to upgrade every time you load the app is troublesome.

The projector need to be whitelisted by NF so that the netflix app can update itself when it needs to.

please DO NOT update the NEtflix app :slight_smile:

Hi @PhillipsNono,

I am not saying that I would let the Netflix app update itself at this time. I will use the version as provided within the firmware.

That having been said, I look forward to this issue being resolved by the PPM being properly whitelisted so that the app can update on its own, when needed.

Widevine Certification has no meaning where Netflix is concerned if the App still has to be hacked to make it work properly …

Any idea when we can expect the PPM to be properly whitelisted, and any indication from Netflix as to why it isn’t right now?

1 Like

It seems to be a bypass of the whitelist, not a bypass of L1.
For the whitelist itself, quite difficult to get for a projector (maybe after few hundred of thousands will have been sold).

1 Like

Can you share the version it is supposed to be, please?
I just want to crosscheck against mine. I may have updated it.

1 Like

Seems to release note mentions we should not update Netflix or YouTube S app on our own?

Can anyone who got a PPM follow up on that question? I just got my PPM and I did definetly not update the app myself, but when I run the Netflix test pattern I only get 854x480 resolution… However, when I open the app or the aptoide store, no update is available, so I guess It was updated with the newest firmware update? My Netflix-version is 4.16.3 build 15172.

4.16.3 build 15172 is the latest version

Are you giving it enough time to buffer?

Also test with season 2 ep 8 video.

1 Like