New Update Issues - Manual image, netflix/prime, etc


Just updated to latest. Initially it seemed netflix and prime werent working. Tried to update but it didnt work. Then tried wifi and that didnt work so did a factory reset.

Now I have a much different image size than before in a trapezoid form. Calibration is not working even with tilting all over the place and I seem to have lost the four corner manual calibration. That option is gone.

My zoom or normal image is so massive now compared to before.

Netflix and wifi, etc still not working.

I have factory reset twice.

EDIT: not sure why but netflix just wont update to new version. when i uninstall through aptoid it shows it kind of still there as an icon. click on it to open and asks to install which it allows and successfully installs. I sign in now but the app acts strange and i cannot scroll down with directional or dragging with bluetooth remote cursor.

  • Netflix (and MX Player) should NEVER be updated manually, the firmware updates will take care of that for you.

  • Calibration should be done with the surface on a level surface. Once finished you can position it the way you need to.

  • Manual 4 Corner Correction reappears in the menu once you disable Automatic Keystone Correction.

  • With latest, can I take it you mean firmware version 1.0.29?

  • Try a factory reset with the PPM on a level surface, then once done tilt it to the desired position. Do you still get the weird image size and shape? Also, is this when using internal apps, or with one of the external inputs?

1 Like

Thank you. found that if i used the auto calibration button on right to set to manual the manual calibration didn’t show. when i clicked on the left side of it, it showed up.

it is the latest. i did the factory reset and followed through and it seems it’s back to normal. all issues were with apps.

i still can’t get amazon prime to work. i checked the hidden settings and everything in the forums but the app loads fine without any images coming through. when i search it seems to pull up the right content but again cannot play or get any images to show.

netflix and other things work fine.

Make sure you’re not using the Android TV version but rather the regular Android version of Amazon.

This worked. I tried the app stuff before and eventually found the info from a previous thread. odd thing is even after factory reset it seems the system is downloading an android tv version. can this be confirmed?

the other problem was when prime is deleted and i go to download it again, the main option was android tv.

had to look for other ones and there are two options. one is instant video or such and another option. sorry after a few trials i cannot remember which one i ended up with but seems to work now.

my only theory is that the update switched me to the android tv version? worked fine until the upgrade.

thank you very much for the help.

1 Like