No USB or HDMI in input list

Hello Team, I want to play movies from my external hard drive, but I cannot find my USB in the input source list.

Please tel me how to add ALL my preferred inputs in the list.

Only USB C and HDMI available.

I need USB Mini SD and ALL channels open to me.
Please advise…

You should not look for USB content on the input list, as it only shows inputs capable of carrying video signals, which is true for USB-C and HDMI. *

Your content on the USB storage and SD cards can be found by accessing them directly from a file manager like the one built into the launcher (Settings - File Manager) or any app of your liking, or by starting a media player program, again either built in like VLC or MX Player, or one you download like Kodi for instance.

‘* (carrying video signals using standard protocols like HDMI, not some exotic video over USB kinda stuff)


Hi IvoG, The file manager does not find anything. External drive plugged into USB, all set to go - not finding my files / films ( all in .avi and .mp4 ).

I can see a set of sub folders: LOST.DIR, ANDROID, etc but nothing that seems to be helping me play my films.

I boight this projector so that I could watch all my films while camping. Please can you instruct me how to do that. I have looked at all video I can find, chats, threads. nothing clearly states how to play from external hard drive.

I have a mac, but have not formatted all of my hard drives to be Mac only…
PLease help!

For me if I can’t watch movies from usb I’d rather have a refund.

Just to make sure, you are using the USB-A port on the PPM (not the USB-C)?

How is your USB stick formatted?

Have you tried MX Player or VLC?

I’ll do some tests and take some screenshots for you later tonight.

OK. I have put my films onto a USB stick instead of plugging my 1TB external hard drive directly into the USB port. That works! I can download a few films at a time onto a stick, plug it in the back and find it through the “file manager” in “settings”. All good folks! Very happy to report good news. Phew!

1 Like

This makes me very happy. Does it play mp4 and mkv ones.

When you connected the 1TB drive, was your PPM connected to the charger? If not, you may want to try that again with the charger connected. If the charger makes no difference, then the drive needs more power than the PPM can supply. You may need to have an externally powered USB hub to connect the drive to the PPM.

Edit: @Alex_Shirley-Smith, which brand and model is the external 1TB drive, out of curiosity?

1 Like

I have several different ones, but the ones I tried still didn’t work when the power cable was plugged into the projector.

New question: How can I connect two sets of Blue tooth headphones to the projector at the same time? I am sure I read that up to 4 sets can be connected simultaneously…

Also, I see there is an option to have files on the projector’s internal memory. How do you transfer files ( films ) onto the internal memory? It is a drag and drop action somehow? I cannot do this the way intuition dictates…

Hasn’t been able to play mp4 yet, which is strange because VLC usually plays anything.
IvoG - any ideas why mp4 isn’t playing?

This apparently doesn’t work yet due to the drivers for the BT 5.0 chip not yet supporting it, but it’s being worked on by the BT chip manufacturer, as explained in this post:

You’ll have to use the file manager to do that, or use an app like Total Commander which allows you to have two folders side by side and copy between them.
See my post on how to do this:

If you could share an MP4 file that doesn’t play on yours, I can also share one that plays on mine for you to check.
Actually, here you go, this file plays fine on my PPM with any of the apps. Download it on your computer to a USB stick and try it out: