NowTV App not working

Hi all,

So I’ve received my Picopix and I’m loving it. All apps are working fine for me currently but then only issue I have encountered app wise is when downloading NowTV from the app store, upon opening it the NowTv logo is displayed the wrong way round and then it just closes.

Has anyone had any experience using NowTV with the Picopix? If so does someone have a solution?

Many thanks,
Tom

When you say “wrong way around”, do you mean turned 90 degrees? If so, this could be a case where the app thinks it’s in portrait mode when it of course actually should be in landscape. You could try installing an app to force landscape mode and see if that helps. See this thread: Default "Force landscape" or add option to change the orientation. I’m not sure if that helps with the app closing though. It might, it might not.

Also, which version of the NowTV app have you downloaded? My quick check on the Aptoide web site showed that there are different versions to choose from.

Also 2: great to hear that you’re liking it! Looking forward to getting mine any day now.

1 Like

Thanks Seb! I’ll give your suggestions a shot and post back later tonight once I’ve tested.

I think you’re right about the app thinking it’s in portrait mode as its turned 90 degrees like you mentioned. So I’ll try that and if not I’ll possibly try another version.

I’m sure yours will arrive soon, you must be itching to grab your hands on it!

1 Like

I’ve installed the screen orientation app, this has solved the issue of the app opening the wrong way round. However the application still closes once the logo has been displayed for a few seconds.

I have tried all the Now TV apps and the same thing happens. The older version loads and let’s me login however it wont let you play any films as it says it doesn’t support streaming via HDMI from a mobile device ( Probs a glitch as it’s an older app).

Sorry to hear that. I don’t have Sky here where I live (I’m not sure if that’s a good thing or not), so I can’t really test this myself. Hopefully, the UK gang here on the forum can find a solution to this.

1 Like

Maybe NowTV has a website where you can stream content.
Try with the Firefox embedded web browser.

Hi, I’m sure I got it working fully using aptoide, when I next boot it up I’ll try and find out which version I have. I know there’s an Italian version that didn’t work. You also need really solid wifi connection for the app to work, otherwise it acts like you described. It’s much easier to plug in a dongle though, even with the loss of BT functionality etc. The OS is rubbish on the PPM at the moment so bypassing it massively improves the experience. I now use a Roku stick which is exactly the same as a NOWTV stick but with better functionality and often cheaper.

We do need a decent PPM / user friendly app store. Fingers crossed it’ll happen.

1 Like

I think we need Philips to contact Sky and NowTV and ask for the PPM to be supported by them officially in their App. Even AndroidTV has limited support by them. Looking over the web a lot of developers are complaining they don’t even use widevine l1 and the way they have implemented their App streaming service is rubbish.

It’s probably just down to having the wrong version of the app. We just need a decent app store that only offers what is compatible instead of these unofficial stores where there’s a massive jumble of versions. For us non-techys it’s a real chore, I hate installing, testing, uninstalling over and over.

I definitely got it working, in conjunction with one of those screen orientation apps.

@Craig_Cr Thanks Craig, would really appreciate knowing what App you’ve been using when you next boot up :).

Many thanks!

I have the version 10.11.0.3006289 from Aurora and thanks to the folks here solved the orientation issues with the Set Orientation app. App looks good but when I try and open an video I get this error message. Has anyone successfully watch video content from the NowTV app?

Viewing Stopped
Sorry we don’t support HDMI streaming to your TV from mobile devices but don’t worry there are loads of ways to get NOW TV on your big screen. Find our more at NowTV.com

1 Like

@Matthew_Rose I had the exact same issue when trying out one of the versions. I was so hopefull until that error message came up!

1 Like

Err soz, but it appears I was wrong. I get the HDMI error message too. It seems to think the PPM is 2 devices. Back to using a dongle.:sleepy:

2 Likes

Thanks Craig! Not to worry! With the Rokubsticks do they require a power source or just simply plug into the HDMI?

@PhilipsEngineering are you aware of any solutions?

You could try asking NowTV nicely about this, if you haven’t already done so. Perhaps there is an easy fix that they might implement in the app? I found this email address on their Google Play Store app page: NowTVAndroidFeedback@sky.uk.

1 Like

Solved the orientation issue with “Set Orientation” app from Aptoide; got an app that didn’t close instantly by copying the apk from my tablet (using the Assistant for Android app to backup an apk); but now hitting this weird HDMI connection error - please shout if you overcome this

Can you elaborate a bit more on what you mean by this? What’s the error message, where and when does it happen, etc.

I think it’s this error. It comes when trying to actually start playing a video.

2 Likes

Ah okay, so still within the same app, noted.

1 Like

yes, that’s its! Thanks! I call it “weird” as there seems no reason to interact with HDMI at all

1 Like