Patched Netflix TV version instead of the mobile version


Currently, the pre-installed Netflix app is a patched version of the mobile version of the app. Navigation is done mostly by simulating touches via the mouse cursor. This is not ideal in a lean back setup. The most problematic I think is that playing and pausing cannot be done using the OK button and the Philips remote does not include media buttons so doing these functions will require you to use the mouse cursor which is cumbersome.

Proposed Solution

Pre-install a patched Netflix app of the TV version. We’re using a patched version anyway so why not use a patched version of the better version of the app.

I have proved that this is technically possible because I found an apk that works on my PPM and plays full HD and with TV UI. It is an old version though and obviously no assurance that it’s safe to use.

I took the risk and tried the apk I found in XDA. You can find it in the link below.


Are you still using this version @kugiigi and any downsides to it?

I still have it but I’m not using it much lately. It’s more prone to artifacts and crashing/hanging up which requires a reboot to fix.Those issues also happen in the normal Netflix app but they rarely happen. To me, the main advantage of the TV UI is the easier way of pausing and playing using the included remote but since I have my own airmote with media controls, it’s easier with it. Another minor thing is that the normal app tends to be more aggressive lowering the resolution especially when starting a video while the TV app most of the time starts with HD resolution…

1 Like

Very interesting, is the TV version you have more recent than the current Philips version? Also what app are you using to download stuff directly onto the PPM. The built in Firefox is no good for this so I just got Opera but am yet to try it out.

Also, is it fairly easy to go back to the official Netflix version provided by Philips if things go wrong?

It’s a very old version as well. Sadly, Netflix has more tight security in their apps now so they can’t be easily patched for whitelisting. I’m using Brave browser for general downloading but for apps, I’ve installed a few alternative stores - f-droid, apkpure and aurora store. I don’t really use Aptoide anymore.

1 Like

I just tried this version and the interface etc all loads well and is super easy to navigate and I can get the audio but the video isn’t visible. I mean the app shows loading and the percentage even increases but the video has already started playing based on the audio that I’m hearing from my speakers. Is there a workaround?

Hmmm, I’m not sure why but that doesn’t happen on mine.Have you tried rebooting?

By the way, I forgot to answer your question.
This TV version is a separate app so no problem installing it with the default netflix app/

1 Like

Haha yes, I figured that bit. No, I didn’t try a restart but will do that soon!