Physical keyboard disposition always in qwerty

System 1.0.25
Launcher 1.3.9

French is chosen in language
Android AOSP or keyboard

The virtual keyboard is in azerty, but the physical keyboard (bluetooth connexion) stay in qwerty.

When I have problems of this kind, I’m used to External Keyboard Helper, but It doesn’t help even when french is selected for the physical keyboard…

How can I get the azerty layout also on the physical keyboard?


Interested in the solution, as a french user too :wink: !

1 Like

Have you checked if an external keyboard settings appear in the hidden Android menu when your keyboard is connected? I think this settings is separate from the on-screen keyboard.

1 Like

Hello guys, you acn also install another keyboard like Swiftkey or Simple KeyBoard.

Finally, the EKH appears in the keyboard choice after a reboot. Now, the azerty layout is active for virtual and physical keyboard. Everything is fine. I consider the problem solved. Thanks.

Indeed, and it solves the problem. Thank you for your help. Best regards.

I don’t understand why, but I can now have the azerty layout on the physical keyboard on AOSP Keyboard even after uninstalling EKH, GBoard or Swiftkey when it was impossible before I use EKH.
Unable to explain why. But everything is fine!

After connecting my physical keyboard (dedicated dongle in the USB-A), as @kugiigi said, I’ve seen new settings in the hidden Android menu where I’ve been able to select French layout without EKH.
But maybe the installation of Switkey 1day before helped in some way…

This difficulty to activate the french layout is perhaps due to the bluetooth connection. I can’t explain. Thanks for your answer.

1 Like