PicoPix Max no longer charging (Request 23808)

I have not used the PPM in awhile since Feb, turned it on and downloaded the latest firmware and updates, and left it to charge it overnight, a red LED appeared, so all seemed well.

In the morning, I realised it only charged to around 60%. I tried unplugging and replugging, but the LED did not come on. Turning on the PPM showed normal battery status (not charging).

I have tried the following steps

  1. Changed to Ugreen USB-C to Lightning cable, with original Philips charger, able to charge my iPhone XR
  2. Changed to a working 30W USB C UGreen charger, with original Philips USB C cable, not charging
  3. Changed to another Anker USB C - to USB C cable, with original charger, not charging

I think there is something wrong with the battery or system. Sporadically, while swapping the cables and testing, the Blue LED would come on briefly then disappear.

Kindly advise how I can fix this or get a replacement, thank you.

My order was from Indiegogo

Contribution ID

A post was merged into an existing topic: Battery not charging