PicoPix Max stopped working while in use, and is now dead

I was using the PicoPix Max last week when it suddenly turned off. The bulb went out, the fans stopped, the power LED turned off. It wouldn’t turn back on, so I left it for a couple days. When I tried again, nothing. The LED doesn’t even blink when I reinsert the charger.

Some notes:

  • I’ve exclusively used the provided charger and USB cable
  • Room temperature was fairly low when this happened (around 20 degrees Celsius)
  • The projector itself has never been dropped or damaged in any way
  • As mentioned earlier, the LED is not responsive even if I press the power button, the remote, or reinsert the charger
  • There are no fan noises from the projector

Has anyone experienced the same thing? How do I get support or a replacement unit?

Thanks!

Looks like I might be facing the same issue. Just now the projector turned off and no power light is coming up either. I think the power adapter is blown. @PhilipsEngineering @PhilipsSupport any help on this please? The projector is not turning on anymore and the power led is not turning on at all

I also tried to turn it on without connecting the power supply. But it doesn’t turn on either. I am just using the power adapter supplied with picopix max. Do you think the problem is with the power adapter or is it with the projector itself? I also sent an email to support regarding this. Awaiting reply.
@PhilipsIvo @PhilipsEngineering @PhilipsSupport