PicoPix Projection stopped . Can hear fan. Can also listen audio through airplay

Hi Philips and other folks. I got my PicoPix max on jan3. When i opened there were lot of issues but with software update things got better. I played some random video from YouTube for half hour and suddenluy pico pix stopped projecting. It was blinking red and blue.
I stopped and tried to turn it on . It turns on but no light. I can hear autofocus and fan sound/.
I even tried airplay some song. I can hear the audio but the video or no light is projected .
I contacted Philips through the email I’d they provided but no response from them .

I am really worried.

Seems to be a failure, maybe on the DLP side.

If it should be replaced, the process is to send an email to Philips, but they are overloaded these days and it may take several days to have a response…

In another thread Philipps said that Red and Blue Flash means there is a problem with the Powersupply. They suggested to load the PicoPixMax while turned off with their own cable. Try this! Maybe it’s just that!

2 Likes

Hey, did it work what @Gizem_Goezmen suggested? If not, just have in mind that Philips are dealing with a lot of e-mail at the moment and they’re trying to streamline the communication through the forum and e-mails. They were pretty clear in their last messages that they’ll support as needed.

Otherwise @PhilipsEngineering can also help with this.

Cheers,

Can you also, when the projector is ON, press on the remote control MENU KEY or on the FOCUS keys to see if you have a UI coming up?

Hi …
I tried them multiple time. No improvement. No light projecting from the projector.

Can hear the fan noise. Pressing remote also has no change.

@PhilipsEngineering @PhilipsNono
I am really concerned about this. It has been 3 weeks since I emailed. No response till now.

Did you send an email or just used the forum? Mine stoped working after ~1h and looks like shows close symptoms with yours.

Hi Marctux, I did email them the very instant. I emailed them on Jan 3 to the email id they provided for bugs.
I sent another follow up on jan8 . Till now i havent got any response from them.

Did you get any response . ? When did you email them .

Some clarification what’s going on found in another thread:

Hopefully that would unclog their support inbox.

Hi @Manikandan_Sriram, have you followed the troubleshooting steps here: Troubleshooting: Projector won’t power on / no picture display / shuts down soon after starting

Can you please post your findings? I think it’s because the power adapter is either faulty or you’re using a 3rd party adapter. But please follow the process above to get clearer info. Thanks and sorry for the late reply, it’s now down from 500 to only 387 emails to reply!

Check Power Adapter and USB cable

  • Are you pressing and holding the power button (on the projector or the remote) for a few seconds? :Yes
  • Are you using the the supplier power adapter and USB-C cable? :
    Yes
  • Do you see red/blue flashing LED on plugging in the charger? This means the power adapter you’ve connected is not supported. Please use the supplied power adapter. :
    The first time it happend it showed red blue light. It was in middle of projecting a video. It stopped and then never played again.

If you’re using the supplied adapter and cable, continue to the next section.
Yes I am using the same one provided by Philips.

Check battery charge status

  • Make sure the projector is powered OFF.
  • Connect the power adapter to the projector. Make sure you plug it into the right side USB-C port (charging port), not the left side (video port)!
  • Does the LED turn red? If yes, let it charge for 3 hours until the LED turns blue. Then unplug it, and power it on. Does it work?
  • If the LED doesn’t light up at all, check that:
    • the adapter is receiving power from the wall socket.
    • do you have another USB-C device? Can the PicoPix adapter charge that device? If not, the adapter may be faulty.
  • If the LED lights up blue, it means the battery is fully charged. Continue to next section.

No BATTERY ISSUE. I can hear sound. I can even listen audio in airplay.

Check display problems

If your projector can turn on but doesn’t display any picture, check this as you power on the projector:

  • Do you see the white Philips logo startup screen?
    • if yes, but there is no picture afterwards, check that all cables (HDMI / USB-C) are unplugged.
    • does pressing the home button on the remote or touchpad causes the home screen to appear?
    • does pressing the autofocus button on the remote show the focusing screen?
  • Does the projector power off shortly after showing the home screen? It could be a thermal shutdown. check next section.
    No effect. I tried pressing button,touchpad etc. No change in display.

Thermal shutdown

If you don’t see the Philips startup screen, or the projector powers off soon after starting up, check the following:

  • Do you hear the fan spinning up when you power on the projector?
  • Do you have at least 30 cm free space on all sides of the projector to allow free movement of air?
  • What is the altitude of your city? (the atmosphere might be thin!)
  • What is the room temperature where you’re using the projector?
    Yes I can hear fan spinning , My city is 150 m above sea level. There is enough air movement. And room temprature is 22 Celsius (72 Farenheit)…

I am sure its a hardware issue. I am really worried @PhilipsEngineering. I have emailed them thrice already. No response. What should I do next. I am posting the same on the Troubleshooting thread.
Regards,
Mani.

Hi Manikandan and thank you for the throughout testing. I wrote you in another thread on this topic. Please try to avoid duplicated posts. If you want have troubles getting our attention, you can also send a direct message or one to the moderators group.

Hi @Manikandan_Sriram have you received the Return Form already?

Hi @PhilipsEngineering I had emailed to bugreport@screeneo.com on Jan4. I only got automated email reply. Apart from that I didnt get any official email
I havent recieved any return form either

Hi @Vin , Sorry my intention wasnt to spam. I though the other thread was managed by someone else . I just wanted to make sure my case is not ignored.

1 Like

I had emailed bugreport@screeneo.com . Should i email support@screeneo.com.
Okey sending one right away. Thanks

Yes, bugreport@ is no longer used. Use support@screeneo.com.

Let me know personaly if you don’t have a rely in the next few days.

@Manikandan_Sriram - was your problem solved? My projector is now showing the exact same symptoms. I just sent an email to support@screeneo.com and report it, but I’m curious if you have heard anything back.

Thanks.