Picopix turns on but no picture

We’ve had the picopix for just over a year now and it’s had its issues but nothing terminal. It’s sometimes frozen on a picture with audio still going with the only fix being a hard restart. It’s also sometimes started to turn on (fan going, projector lamp turns on) but doesn’t show any picture (lamp stays on). Again a hard off and on has done the trick. Now the hard off and on doesn’t fix the turns on but no picture problem. This happens when plugged in or running on battery. It just shows a faint lamp light, fan going, but never gets to the home screen.

The last thing we did when it was working was run the four corner correction calibration as one of the corners was a bit off.

Has anyone else had this problem? Is there anything else that I can try?

It’s still under warranty so could go down that route.

I should note that the initial white screen with Philips logo appears before going blank. Fan cuts out mostly after but the lamp light stays on, just very dim. Almost like it’s freezing when trying to start up

I have exactly the same problem! For me, it appeared after the last update.
When testing I now realize that it’s still working as a projector. If I connect my laptop (HDMI) the picture comes on but I still can’t access any menus…

Found a solution in the tips and trix-section! :slight_smile: Did a factory reset and now it works again!

" Or for future reference, you can boot into the stock recovery (for factory reset) as follows:

  • turn the projector completely off (e.g. long-hold the power button)
  • make sure there is nothing in the USB-A port
  • insert a pin into the ‘recovery’ pinhole. Two pinholes are one the side of the PPM; recovery is the one closest to the usb-c port (the other is a hard reset)
  • while pressing the button inside this pinhole, power on the projector with the power button. Release the power button, then release the pinhole.
  • You should get a screen with a robot, and the text “no command”. This is the stock recovery.
  • Press the ‘power’ button, and while holding it press ‘volume up’ on the device. This should bring you in the recovery menu.
  • You can navigate the menu with the volume keys, or the remote control via IR.

It worked!!! Thank you so much!! For future people, after turning on while holding the reset button and power, the screen shows a list of options. Go down to “wipe all(factory reset)”. It asks are you sure, go yes. It then returns to the options screen but doesn’t look like it’s done anything. It has. Power off then turn on and you have a restored projector!