Plex TV mode issue

Installed Plex but unable to set the TV mode, even after setting it, it revert back to Phone mode

I have been waiting for weeks to have some feedback about Plex app on this device, looks like bad news.

But Plex app quality has never been top of the line in my experience, lots of bugs on my current Android devices especially, while app on iOS is always performing better with less bugs. So maybe PPM is not the one to blame on this issue too, but Plex app might be :slight_smile:

I heard someone else got it to work but I dont think they got the app from apptoide I think they installed the APK.

I have never had an issue with Plex on my phone or on my Shield TV. Unfortunately I do not have the ppm yet to figure this out but this is my main use to watch my 2k movies so will figure out how to get this to work


I have installed Plex from Aptoid store of the ppmax and it works flawlessly.
Only issue was the login screen direction which was in portrait instead of landscape.
It keeps the TV UI after restart and connect without issue to my server (Plex media server on Shield TV connected to another TV)


One thing to add that I heard from someone who recieved those device already. If you plan on using Plex with the ppm outside of your local network you are going to need to have a Plex pass. Because the device is not hooked up to GMS you won’t have the option to pay the 5$ to unlock just the device.

That being said on your local network it should work no problem with or without a Plex pass and you are streaming locally.

I have no problem using Plex or Emby apps to stream from my Plex / Emby servers when I am not on my home network. Of course you have to ensure that you have the appropriate port open / forwarded on your router/firewall to ensure that you can stream beyond your own network.

Do you have a Plex pass? If you have one then it shouldn’t be an issues. You can’t stream outside your network without a Plex pass or paying for a one time use.

Good to hear.
In my use case, PPM will be used mainly to watch movies through Plex.

Nope, I do not have a plex pass. I simply connect to my own Plex server.

Sure, with a plex pass I could set up multiple users who would each have their own profile when connecting to my server, but I built my server to be used by me, when away from home, so only need the one default profile.

I have not paid a cent to plex, and the android plex app does not require a plex pass to use with your own server. Clients on other platforms do, but not the android one.

I thought outside of your network you either needed to pay a one time 5$ pass for a device or have a Plex pass to access outside of your local network.

Inside your network it should work no problem

I have a couple of Firesticks with Plex, my android phone, and of course CHrome browsers that I use to connect to my plex server. I have now also loaded Plex on the PPM via the Aptiode store and logged on with my account and have streamed to it as well.

No PlexPass, and no issues …

Again, this only works for a single user account, but it works just fine …

1 Like

Does anyone know if you can use the Plex PPM app to play local storage off the SD card? I have plex pass.

I know you can play off the VLC player, but I prefer the UX of Plex.

Cheers you lucky lot :stuck_out_tongue:

Anyone have issues connecting Plex to their Plex server. It asks me to go to but the 4 digit code is never recognized

1 Like

I’m getting this same error. Not sure how to get around it.

My only issue with Plex is sometimes it will transcode to SD without reason (5ghz Wifi, 3 meters from a router), then sometimes it’s fine.

I had to uninstall and reinstall a few times, I also tried a few different versions but eventually it worked for me and have had no issues since.

1 Like

Haven’t checked that yet will keep and eye out and report back if I notice.

1 Like

I have the same issue.

I solved this by installing a earlier version of the app from June. I upgraded the app fine after :+1:

1 Like