PPM turns off video from Chromecast dongle

I have been using a Chromecast dongle to stream to my PPM and have been very happy with this. Recently though I have found that after a period of time (often around 20 mins), the PPM will stop displaying the video from the Chromecast, but continue playing the audio. The PPM becomes unresponsive and requires a hard restart (long push on the Power button on the device). The Chromecast remains responsive and can be paused etc.

Troubleshooting I have tried:

  • Changed Chromecast power source from the PPM USB-A to a 5w wall adapter power (note the PPM has previously had enough power for the Chromecast dongle to run no problem)
  • Changed the power cable for the Chromecast
  • Changed the Chromecast dongle itself
  • Tried with the PPM plugged into power and just running on battery
  • Changed the app source (tried Disney+ and local New Zealand app Spark Sport)
  • Kept the app/connection ‘active’ by not closing the app on my phone, and pausing every few minutes (i.e. issue is not related to inactivity)

I’d love any suggestions please! Currently this looks to me like a PPM bug introduced in a recent firmware update.

Just in case anyone has a similar problem, I solved this by doing a factory reset from within the Settings.

We are currently testing with the Chromecast Ultra and can’t reproduce the issue even after 1h. Which Chromecast model du you have?
THanks

It was happening with two separate Chromecast 2s, and also an Ultra. As mentioned this was resolved with a factory reset, not sure what the problem was.