PPX-360 will not connect to wifi - stuck in endless loop

Bought a PPX-360INT in August. Used it twice.

Just tried to use it again and it will NOT connect to WiFi (I tried multiple networks at this point).

Silly me finally decided to do a Factory Restore on the device thinking maybe there was a faulty network causing the issue.

Now the device boots up.

  • ask for language [English]
  • ask if I want to connect an Android phone [skip]
  • sees my network [Connect]
  • comes back with “Couldn’t find Network” [try again]
  • states “Network is a saved network” [connect]
    and around we go in an endless loop. I have asked it to forget the network, tried connecting to my phone, typed in the network manually. Nothing can get me past this screen.

The unit is on software version 1.8.60

I wanted to see if I could access the hidden wifi menu I read about, but since I cannot get to the homescreen I cannot get to settings. The only menu I can access it the green menu.

Does anyone know a trick to make this unit useful again or is it just a fancy paper weight now?

Can you try one thing for me?
Put your phone in hotspot mode, then check if the projector sees it. If not: faulty Wifi chip, need to exchange.

It sees it, but when you try to connect it then says “Could not find iPhone”. So it sees networks to start with, but the moment you try to connect it can no longer find them.

I am wondering if I should try to update the firmware using these instructions, but I am a little hesitant to start undoing screw on the back on the unit. https://support.philipsprojection.com/hc/en-us/articles/4403181872530-How-to-update-the-software

(I don’t want to risk voiding the warranty, but the instructions are from your own website)

Try to use your phone as a hotspot again but this time try to do so somewhere else, not at the place you’re having the issues with. So take it to work or school, a family or friend’s house and try there. You can also try any local WiFi networks once at the other location. If it works there but not at home then it could be an issue with the amount of WiFi networks in the area.

I already tried it in multiple places (at home and at a friend’s house to see if their wifi was better). I am current testing at my parents house which is in farm country. There is not another Wifi network available. Just one Wifi network and my phone’s hot spot when I turn that on. The PPX will connect to neither. Not even when it’s placed right next to the router.

Hello, I think it is a defective Wifi Chip.
The best way is to do an exchange.
Where did you purchase it?

AT Bestbuy. It didn’t look like they would be willing to take it back past 14 days though. Do they actually do warranty exchanges?

for sure, this is mandatory, you have 2 years warranty.