Random Returning to Home Screen

My Picopix Max randomly returns to the home screen, as if the home button was pushed. The symptom is inconsistent and random, but gets worse as the unit warms up across 45 minutes. At is worst the unit goes back to home about twice a minute, which ruins the watching experience. Return to home occurs in any app launched, prime video, vlc, etc. It is not a problem with the AirMote, as it occurs even when the batteries are removed from the AirMote. The problem occurred in both 1.0.21 shipped firmware and the current 1.0.24 firmware.

I sent an email with this problem to the @screeneo.com, got a confirmation it was received, but no reply for more than a week now. Hence I am re-posting the problem here.

Not sure how to nail down if it is purely a hardware issue or a software issue… Is anyone else having this issue?


I’ve noticed that the touch pad is extremely sensitive. The slighted graze across the home button on the unit brings it to the home screen. Maybe there’s something going on with the physical home button / touch pad surface on your unit.

That was my first thought also. I’ve tried cleaning the area carefully of fingerprints, etc, but no difference. There’s nothing anywhere close to the touchpad or home button when I have my unit set up.

i believe it will good to get in touch with the philips technical support to see if it’s a hardware issue or software issue.

I didn’t have this problem until I paired the Airmote. Now it happens every few minutes

@fhteagle Is it really like using the home button or the app currently opened shutdown completely? (When you get back in the app, is it still in the same state or does it restart like it was not opened before?)

If the app do a cold start, aka it got killed, on Android this can be symptomatic of memory issues where the Android system ran out of memory and last resort was to kill the app currently opened…

@Guidone -

It’s definitely not an app crash or restart. VLC, Amazon prime, etc continue in Picture in Picture mode. DLNA steaming continues playing audio to BT speakers (but no Picture in Picture). If I’m in “Projector settings” screen, it backs up to the home screen with the right hand menu open, exactly the same as if the home button is actually pressed on either the AirMote or the touchpad home button…

@RTRY have you tried taking the batteries out of the AirMote, and if so does the symptom continue as well? I might try pairing a different mouse and unpairing the AirMote and see if it makes any difference…

That sounds really bad if this is yet another hardware issue… Which looks really like it is :confused:

New batteries hasn’t helped

I meant removing the batteries and leaving then it and seeing if it does it with the AirMote unpowered.

As for me, I unpaired my AirMote and it didn’t do the return to home thing across two compete movies. Paired a Logitech Bluetooth mouse, still no return to home for over an hour. Re paired the AirMote and I the symptom did not return.

I also had not thought of the IR receiver on the PPMax being a possible source of the behavior as well. More to test and troubleshoot if the symptom ever comes back…

1 Like

Actually what happens is that when I try to watch any movie on any app it goes to picture in picture after a minute or two with the home screen in the background. Then I can’t find a way to restore the full screen so I have to restart.

To restore the app you should be able to mouse click on the PIP once (makes the PIP smaller but adds some controls), then click the very middle “square of corners” and it should put the PIP back to full screen.

Can you try unpairing your AirMote, and just control the PPMax using touchpad and/or AirMote over infrared only (will have to point the AirMote at the front of the PPMax for this to work)? I really want to see if this solves the return to home problem for you too…

In 1.0.24 and in 1.0.25, having unpaired and re-paired the AirMote seems to have improved the return to home behavior while watching video. I think it had done an uncommanded return to home while on the settings screen, but that may be a separate issue with the settings “app” instead. I will continue to monitor and just my PPMax and report back here if the problem returns.

1 Like

I updated to the new .25 firmware. The problem of returning to home randomly with PIP continued. I unpaired the Airmote and used it with infrared and the problem went away. I’ve now repaired it and it seems to be ok. Thanks Mr Eagle.
Can you tell me how PIP is invoked?

PIP is somewhat app specific… Some apps are capable, some are not, some need PIP switched on settings. VLC has a setting for “background behavior” I think it is. Turn PIP on in VLC, play a video, then hit home on the AirMote, VLC will shrink to the corner in PIP mode, for example.

Having the same issue with Netflix, and it really sucks. Have 1.0.25 installed. Tried (1) factory reset, (2) uninstalling-reinstalling Netflix, (3) pairing-unpairing remote …

It keeps going to the home screen randomly. I don’t remember this happening before 1.0.25 update

No matter what app I use, after a few minutes the movie minimizes to the bottom right corner. Even set the movie going (Plex, Netflix, Amazon) and pulled the batteries out of the remote. Still happens. Any ideas?

Ok I’ve tried everything to prevent all my apps from minimizing to the home screen and nothing prevents it. How do I contact customer support?


Just received my PPM a few days ago. I navigated through the menu and did some basic configuration stuffs without much problem then I updated the firmware to .25 and tested some of the apps (VLC, Netflix, Amazon) but I’m facing the same issue with random return to the home screen.

I unpaired the remote, removed the batteries, cleaned the touchpad. Nothing changed.

The issue seems to be shared by several other users and the feedback from one of the Screeneo team members in a similar topic seems to point to software issues (which seems reasonable as I did not have any problem before doing the update to .25 while now, even going in the config menu is difficult).

Any news on this issue from the Screeneo / Philips team? As it is, the PPM is unusable which is a little bit frustrating.