Remote stopped working

Hi - my unit arrived a few days ago. All seemed fine initially but after a day or so of lite use including updating to the latest software load, the remote has mysteriously stopped working.

The red light on the remote lights up when it’s used but nothing actually happens a on the unit. I have to resort to the touchpad to control it which is far from ideal.

Any ideas?

I suppose you have tried to restart the PPM?

I had a similar experience at first - the airmote worked out of the box, then suddenly stopped. (The red light would illuminate but nothing else).
I re-paired the airmote via Bluetooth settings and it has worked since then with no problems.
Have you tried to re-pair?

1 Like

Thanks for the pointers guys.

I had tried restarting the PPM several times with no luck.

This morning though when it powered up it worked fine. Strange!

I had not previously paired the remote via Bluetooth so I did that just now and the remote continues to work as expected. Fingers crossed, it continues to work.

Had the same problem with the same fix!