Screen Mirroring not working. MacOS

I am trying to mirror my MacBook using AirPlay but I can’t get it to work. The device doesn’t appearing on the Screen Mirroring list on my MacBook.

Bluetooth is turned on on both the PicoPix Max and my MacBook Air. PicoPix Max is connected to the same network.

I’ve tried both turning off and on AirPlay and turning off/on the “Device discovery tweaks” option?

I have tried 2 MacBook Airs and an iPhone XR. I can’t seem to get it working. Any ideas?

I have paired the units via bluetooth but I still can’t get it to work.

So are you seeing the airplay logo on top of your menu bar like this ?

And does the list look like mine with PPX620 ? what else is on your list?

1 Like

I don’t have anything on the list at all. I have gone into “Settings” and then “Display” to make sure, as the Mirror option wasn’t being displayed in the menu bar like in the picture you sent. No options are available at all.

Some WiFi routers / access points block certain ports and protocols, can you test on a different network or create your own by creating a hotspot on either your Mac or the PPX and joining the other device to it?


Yes it sounds like a network problem, the airplay logo appears automatically in the menu bar after I turn on the PicoPix and the Mac detects another display is available on the network if you have ticked the check box in system preference display setting for “show mirroring options in the menu bar when available” , but even if that box is not ticked it should still be in the settings list

You can also try go in to your modem/router settings and play around and see if you notice anything related that can be changed,
or try switching between 2.4 or 5Ghz wifi band and see if that helps the Mac to detect the display.

1 Like

Something else I just remembered: did you go into the Airplay app via settings at least once in the PPX? It requires you to start it at least once before it will work.

1 Like

I tried another network and all works well now. Must have been blocked on the previous network. Thanks for the help.

1 Like