Screeneo 4 crashes with 4K fire stick

Screeneo is crashing when starting a movie on Amazon Prime.

Firestick: 4k max, in settings already reduced to 1080k
Screeneo U4: latest update

Screeneo starts the movie and is stuck with the video and sound, then switching off automatically. Or just stuck in the beginning, but the movie will have some problems later. The voice is not synchronising with the video, or it just switches off.

I tried to upload a video I did, but new user are not allowed to upload content…

Hello, are you using the Amazon Prime video app from the Firestick ?

Yes I do

a specific video or all videos ? Also, did you set the firestick to 4K or Full HD in the settings?

As mentioned in my first post, i already degraded the 4K down to HD/1080 . But still, the problems with all “new” series like Clarkson’s farm 2 or The Consultant. Both start with problems or not at all. No problem with Netflix APP on Amazon Firestick 4K so far

(I still can’t upload a video to show how it is. Maybe an email address where I can send the video of the problem)

Hello, we just tested and on our side no issues. Can you reset the U4 first ? You can contact us by facebook messenger Redirecting... in order to chat and send videos

Factory reset is done still the same issue. Factory reset done on 4K Fire Stick, too. I set down the settings in the Firestick to 1080 - 60 Hz and I tried with 10 and 8 bit… all had the same issue.

1 Like

Got the same problem with my stick. Beamer is on software version 1.7.
On my Uncles Beamer it does not appear. This Beamer is on 1.5.6 software version …Tried all settings …

Hello guys, OK we will check on our side with different software.

I changed the HDMI port, Factory reset, checked no bluetooth speaker is connected and still same failure

Hello, we just tested and no issue on our side, did you plug your Amazon Stick on a TV to try as well? Other wise we will exchange it. We tried we both UHD ON/OFF on the projector menu.

Hello @Philips_Support_N

I am having the exact same issue as Shakeitbeer.

I assumed a software update would eventually resolve but have not had any luck.

Amazon fire stick is set to max output of 1080p 60hz. No issues with firestick on my TV.

Have tried multiple Projector settings. No Bluetooth being used.

Are you able to advise also?

Thanks for your help.

@Philips_Support_P what do you think ?

Hello all, we are investigating this.

Could you try switching to ‘Game Mode’ picture preset? Does it solve the problem?

Same… changed the present to Game mode. The movies are starting as usual with the sound and picture stutter. After like 10-20 seconds it continues. From time to time it stuck or just switches of itself with the movie.

“old” movies/series without any problems on amazon prime.
“new Movies” (seven kings must die) on Netflix without any issues.

When it stuck the remote is not usable.

Hi all,

Well that’s interesting. I’ve got Fire TV Stick 4k Max, and I’ve just observed the same thing with Prime Video’s “The Consultant”. First episode, first seconds, and the U4 shuts itself down (when resolution was set to “up to 4k”), or stutters for a few seconds and continues to display the episode after that.

What’s also interesting: it seems that first seconds of the episode causes the issue. When started later (continue watching), it seems to work fine.

Not a real study of the problem: I tried two times only and was able to replicate the results as above.


Same here with the Amazon Fire TV-Cube different moves crash sometimes after a cup of second sometimes after 5 or 10 min doesn’t matter which settings I use, and if I start the movie from beginning or in the middle. Back to default settings at both devices won’t help. I run Software version 1.7.0

Hello guys we are trying to reproduce the same issue on our side and will let you know

Guys, can you try something: try to set your AMazon Fires Stick without HDR inside the menu. Can you try ?

same issue with hdr off inside the stick