Serious bug on 1.1.0 [Overheating] <- Fixed in v1.1.01

I have came across a potentially serious bug with HDMI CEC on 1.1.0. Result: The PP Max will remain on with no fan cooling, the device will severely overheat and cause potential safety issues.

HDMI CEC is a protocol that allows you to command and control other HDMI devices, which is found in most home entertainment devices.

Steps to reproduce:

[Note: PP Max is on default settings]

  1. Turn on PP Max with connected device already on [that supports CEC]. In my case, Apple TV 4K.

  2. When the Apple TV 4K goes to sleep, the PP Max will go to sleep as well.

  3. When attempting to turn on the PP Max, the No Signal screen will show, but the PPMax fan cooling will not be on. Device will be extremely hot to touch.

  4. The device will appear to remain functioning correctly [ navigation on the Android interface ], but the device cooling system is completely remain off.

Workaround:

Go to hidden settings menu -> Input. Disable both HDMI control and TV auto power on. Both options are turned on by default

Recommendations:

I personally do not use HDMI CEC. The function appears to be broken on the PP Max and should be disabled by default.

The fact that the device remains on and overheat shows that there might not be a safety thermal threshold to allow the device to shutdown in event of a cooling failure, or it might have one that is not kicking in when needed.

With most home entertainment devices with HDMI CEC enabled by default, this might create a potential hazardous situation if the abovementioned scenario were to occur.

4 Likes

Thanks i disabled this feature.

1 Like

But HDMI cec isn’t working in the first place right? I’ve tried using it with Chromecast but it doesn’t respond to any action at all. Is HDMI cec ever going to be usable?

2 Likes

It’s working, just not doing what it’s supposed or expected to. Proof is in the fact that it’s affecting these users’ devices, and by turning it off in the settings the issues go away.

1 Like

Turn off CEC at the AppleTV also.

1 Like

@PhilipsEngineering can you have a look at this?

1 Like

how to turn off CEC at apple tv and PPMAX?

it’s not working on any cec device I’ve connected…

Turn it off at the settings->remote app and devices->turn on your TV with your remote

When I turned it off, ppm will not wake up on its own anymore. So no chance for heating up.

2 Likes

Thanks for all the suggestions.

But I’ll like to reiterate the two key points:

  1. Most devices support HDMI CEC by default. Not just Apple TVs (e.g. PlayStations and NVIDIA Shields). Leaving this feature on the PP Max unfixed and enabled by default may put people at risk of a significant safety issue as a result of overheating.

  2. Based on some threads by other people in this forum (Search: CEC), it appears that a unit may have damaged as a result of this bug, and another case where the unit was so hot that they had trouble holding down the power button to turn it off .

This raises another concern, on whether the device has a safety mechanism to shutdown automatically in event of a cooling failure / overheat.

Not everyone who purchased/funded this projector is as tech-savvy as most of us here.

I’m not trying to be an alarmist here, but this projector will be placed in many bedrooms and living rooms, sometimes with kids around. Any potential for an overheating concern can become a safety issue.

3 Likes

According to @PhilipsEngineering, there’s a safety automatic shutdown if certain level of temperature reached.

Hello everyone, FYI we are aware of this issue and are looking into it at urgent priority.

6 Likes

Thank you very much @duncan, the problem was fixed now via:

2 Likes

disabling is NOT a fix…

1 Like

It’s a temporal fix… It’s better than having to risk burning up the ppm.

With 1.1.02, it just did the “turn itself on” thing again. The PPM was on, I took a phone call which caused KDE connect to pause Kodi. The PPM went to screensaver after a few min, then PPM seemed to go to standby, then the yellow-orange “No Signal” screen popped up some minutes later. I waited as long as I could stand it to see if the fan would come on, which it didn’t. I finally powered PPM on myself just to make the fan go on. All three HDMI CEC settings were selected off in hidden settings -> Device preferences -> Inputs. No USBC or HDMI sources were connected to device, only AirMote and a BT speaker was paired.

I say again, selecting off CEC has NOT fixed the self power on without fan and overheat bug!

1 Like

But did it actually go to standby or off mode? also it says you’re a beta tester so I’m assuming you’re not currently running any beta firmware?

1 Like

Does PPM have a screensaver? Perhaps you turned it on in the hidden menu? Is that even supported?
Can try disabling it if you did turned it on?

1 Like

Perhaps it has to do with this again

2 Likes

I had turned on the screensaver in the hidden menu since 1.0.26 version. However, I did NOT enable Android sleep after 5 minutes, but that setting was set in that same menu also. I disabled both for the time being, and will monitor the situation…

2 Likes