Service Update v1.1.05 is now available

Dear PicoPix Max users,

An update v1.1.05 is now available for those who are already on v1.1.04. The corrections are:

  • ExpressVPN is updated
  • Device manufacturer ID is corrected to Philips Projection
  • Internal correction to the light engine voltage to solve the problem of DC bias.

Notes:

  • This is a differential update of 25 MB. Differential means it’s available only if you first update to the last full version (v1.1.04). If you’re on any older version, you will first get the 1.1.04 update.
  • This update is only available online.
5 Likes

Whens the next major update? Or have we reached the end for that?

Can’t say I speak for everyone, but its gone deathly quiet on the dev/road map updates.

PPM 2 work now?

11 Likes

I hope to get the wall color settings at least. @PhilipsEngineering any plans on that?

Thanks,

2 Likes

With the firmware update.
HDR and FlowMotion technology (MEMC) are
When will you be supported?

Unfortunately the update is partly a step back compared to the previous version.
Manual Keystone worked with the HDMI input in the v1.1.04. As soon as i updated to v1.1.05, the manual Keystone wasn’t remembered at all when switching to HDMI!

1 Like

It was remembered all right, just not applied. And not just for HDMI but for any source.

This has now been fixed internally, so it will be included in a coming update.

1 Like

What is:
“Internal correction to the light engine voltage to solve the problem of DC bias.”?

What problem does DC bias cause?

1 Like

Not sure if this coincidence, but now after upgrading to this new v1.1.05 my projector keeps on shutting down randomly, mostly lasting barely a minute uptime. Otherwise had no problems since getting it a few months ago and love it.

I’m concerned this voltage correction in the update has something to do with it.

Has anyone else encountered this after updating?

I’m contemplating rolling back and install v1.1.04 again offline with USB stick, but not sure what to do with the device now most the time automatically shutting down in about a minute. Concerned then turning the projector into a brick. Is it maybe best to reset and try from scratch updating?

What brightness level setting are you running it on, and is this on battery power only?
1.105 was an APK update only, so not sure how this could’ve caused the issue you’re now facing.
In any case, rolling back requires you to do a cable restore procedure, which you’ll have to request from our support desk via an email to support@screeneo.com .

Looks like this update has a few regressions/bugs. I’ll wait for the next one :smiley:

1 Like

Is it correcting the freezing issue? Or is it really a Hardware problem? Still waiting for your answer on my e-mail :slight_smile: @PhilipsEngineering

1 Like

Thanks for the dev team for the continuous updates, can clearly see the UX getting more polished with every update. For future versions would be great to have:

  • Support for Surfshark VPN (unless you made some exclusivity deal with ExpressVPN)
  • Saved profiles for the corners (I use projector in 3 different places like ceiling, wall and friend’s place) would be best if I can switch between saved corner settings instead of everytime manually adjusting them
2 Likes

I’ve done some more tinkering.

Now it looks like the projector kept on shutting down to protect itself from overcharging the battery.

The reason I believe this is as most of us had the problem with the battery charge never being shown correctly on display. In my case pretty much consistently about 96%. Once I unplugged the USB-C power adapter I had no more outages. I ran the projector unplugged fine from 96% to 76% without issues. Then I plugged back in the power adapter kept the projector running and it charged while playing without problems to 100%. That then also ruled out any possible issues with the power adapter.

Several hours later I turned the projector back on and it showed battery drained to 98% even though it was plugged in constantly. But only when it was turned on it charged back to 100%. For now it has run without another forced shutdown. The difference this time is it actually charges fully to 100% vs before just showing max 96% and because of that tried keeping charging triggering a protective shutdown to prevent overcharging. At least that’s what I believe happened here and only Phillips can confirm.

So, based on this I can’t tell if this a new behavior because of this v1.1.05 or is just a lingering problem with the charge display and just has caught up with me.

For now I’m up and running again, but can’t wait for this charge display and handing to be fixed soon in an upcoming update.

3 Likes

this made my ppm mutch cooler than before now i can run long time and it just get normal warm ontop
before 05 it was HOT… good work

2 Likes

What problem does DC bias cause?

I need to know in order to decide whether to update the firmware.

Cause

if it ain’t broke, don’t fix it.

1 Like

I would also be interesting in that information. Does it harm my PPM when I do not have that update yet?

2 Likes

Hey Holzhausen, did you realise that you can install Surfshark through the Aptoid TV app? Just use the search function to locate it. Came up as “Surfshark VPN for Android”.

1 Like

Where is this update? i can not find the link
thank you!

So you can only update v1.1.05 with the Picopix Max, it’s not possible to do an offline update.

1 Like