Software update ending up in no picture

I’m in big trouble after my last software update. :thinking:

I’m not sure of the version numbers and at the same time I can’t check it either since I’ve no longer have a picture.

But as I recall it I was on v1.1.02 updating to v1.1.04 and that all worked fine (online). Doing another check and finding v1.1.05, downloading and installing it.

After that the projector automatically reboots of course. Starting up again gives me the white startup screen with the Philips logo, but after that it just sits there with dim light and nothing happens.

Anybode else experienced this and know how to fix it?

A little extra research… It seems like the Andriod system is bricked cause of the upgrade. The system won’t start up. I still get the Philips logo and then the dimmed light projection. Plugging in a HDMI source and that will project…

Please request the firmware restore procedure via an email to support@screeneo.com with the subject line

PPX620 Firmware Restore Procedure Request

Thanks! Will test that. Be back with the result here.

3 days to get an email response in average?! For something that could be added as a Guide at this community!

A little extra search 'cause I didn’t had the time to wait 3 days for support, and I found the way to hold the reset button with a paper clip and power on the device.

The reset button is one of the two small holes on the right hand side of the projector - the one closest to the USB-C power port.

I got into the system boot menu, did a Factory reset, rebooted the system and I’m up and running again!

2 Likes

same here :frowning:
welcome to windows95

Hi JompaBoy,

here happend the same today (Update from v1.1.02 to 1.2.1) → procedure you described worked!

Paperclip in the left hole while booting, then use the power and volume keys for the navigation.

Troubleshooting note for @PhilipsIvo : In my case I had an wirless Keyboad/Mouse adapter connected while updating - maybe this coused the problem? Also unplug it for the reset!