Software Update stops when "checking the package"


My Pico is still running on software version 1.0.21 as I haven’t done any updates yet, unfortunately. I have tried updating to the latest version of the software but the update always stops when “checking the package” and returns to the menu. The same happened with previous versions of the software. I have tried both online and offline updates as well as factory reset before updating.

Is there something else I can try? Thanks for the help.

Best regards

Hi @Alex1103, v1.0.21 is quite an old version and it’s possible that it can’t update directly to v1.2.1.

You have two options:

  1. If you have a USB-A cable, and either a Windows PC or a virtual machine, you can try doing a complete cable restore: Cable restore procedure With this, you can install the latest software using your computer.

  2. If you don’t want to do that, please let us know. We will provide you v1.0.25 of 1.0.27 which can be an intermediate step before you can upgrade to the latest one.


I had a similar pb, my picomax was downloading, checking and then told me that this was not a valid update package.
I was stucked on 1.1.03…
I did an OFFline update to 1.1.04 by downloading the firmware to the root of a microSD card (FAT formated)
Don’t forget to rename the file to
Then went back to update->offline…

Once done (updated to 1.1.04) i could check for update and update to 1.2.1 ONline as normal.

See INFO: How to do offline software update?

When I upgraded to .04 my normal mode picture became less bright than before…since then I hve been scared to upgrade but I got gedy with the latest one and I paid the price.
I place my pico right in front of my wall and alway get. Perfect auto keystone picture …
After upgrade my picture tilted down from the right and is no longer a perfect rectangle .
Why would u spoil that?
I had to reset but Im back to same software.
A perfectly working pico before .o4 and even after .04 is bad now.

Thanks for the information @Happytoon, we’ll modify the update server to only offer 1.2.1 to 1.1.04 and above. So those on older versions will need to update twice.