Software Update v1.2.1 is now available

Dear PicoPix Max owners!

We are pleased to announce the availability of software version 1.2.1.

This update lays the groundwork for a parallel update channel for applications, in addition to the usual update channel for the system software. In addition to that, we have several improvements:

New Wallpapers

The first thing you’ll notice is an all-new wallpaper selection. We hope you enjoy them. For those who would like the ability to use your own wallpaper: don’t worry, it’s coming very soon!

Automatic update of installed apps

We’ve rolled out the app update feature on a limited basis in this release. Your projector will automatically check for any available software updates for the pre-installed apps. This is done about once per hour, so you might notice an update badge on some of your favourite apps when you come back to the home screen from a movie. Just click the app to install the update. If you ignore the update, you won’t be asked anymore until the next time you restart your projector.

We are releasing this feature in a phased manner to ensure stability. In the next update we will remove the 1-hour wait for automatic checks, add the ability to check for updates manually, and allow the Home Screen to update itself.

Note that we only offer updates for the preloaded apps currently.

We believe this feature will let us offer faster updates for the latest tested version of apps.

Linearity distortion correction

A long-pending issue with the 4-corner correction has been the presence of horizontal linearity distortion. In this update we’ve introduced a solution in the form of “5-corner correction”. When in 4-CC adjustment, you now have the possibility of adjusting the centre point:

Note: when the 4 corners are all set to (0,0), the correction is disabled entirely (for performance reasons). This means the 5th point correction will have no effect unless you also adjust at least one of the 4 corners.

We hope that this feature will help you get the best picture fit in even more locations.

Screen mirroring update

Our mirroring system, AirReceiver, has been updated with improved compatibility for AirPlay and Google Cast. In the next update we will also replace the built-in Miracast system with a better one that’s built into AirReceiver.

Other updates

  • The mouse icon has been changed.
  • Some users reported that Manual Keystone Correction was still not remembered across restarts. This has been fixed now.
  • The first few times you start Netflix you’ll be shown a reminder that you should use “mouse mode” for this app.

How to Install

Just head over to the Software Update section of your projector and update it online.

Alternatively, follow the offline update process.

16 Likes

This is awesome news! I’ve been waiting for the 4cc fix for aaaages!

What improvements have you made to the Google Cast? Will it work as if it has Chromecast built in?

Also can we update directly to this version without having to go through the previous versions first?

This sounds like the PPM is now becoming more of what we were hoping it would be! Very exciting!

The changes are working well. I do wish you would have kept or added some brighter coloured wallpapers though.

1 Like

Hello,

Nice to see there is some product support still going on. I think many owners felt like the projector had been almost completely abandoned by the development team.

Anyway, I didnt see anything mentioned about it so I wanted to ask. When will the functionality be added to be able to adjust projector settings while still in app? (i.e. without having to go back to the home menu). I think everyone would agree that at least options like display mode (energy saver, etc), display settings (contrast brightness), digital zoom, sleep timer, and even keystone & 4CC should be available on hand while in app, otherwise its really tiresome to navigate. For example when i am watching a film via kodi, and midway i feel like im getting sleepy, i have pause the film, get out of kodi to the home menu, navigate the menu to power settings, set the sleep timer and then go back to kodi and then restart the film.

Will this kind of improved accessibility to useful functions while in app be added? Is there any plans for it? and if so, when?

6 Likes

I 100% agree with you on this. Why this wasn’t implemented from the start still boggles my mind. @PhilipsEngineering

1 Like

Hello, this is a hardware issue, not software. If this was possible, we would have done that since the beginning :slight_smile:
We added this features on all our new devices for 2021 though.

2 Likes

To add to this, we are working on an alternative software solution: a mobile app. You’ll be able to use the app to control many of the projector’s settings while watching your content. The app will act as the “On screen display.” Many of these adjustments can also be made while using the HDMI/USB-C inputs.

16 Likes

It nice to have this update. Unfortunately, the USB-C/HDMI connection with macbook pro is still unsolved (even after a few support tickets, etc).

After 5 minutes of connection, the projector goes blank.

So, I am happy that you are pleased to announce this update, but when will you REALLY take care of our problems?

We believed in you, we gave you our money in advance, we trusted you … and yes, you’ve come a long way … but our only wish - to have a good product - is still ignored!

3 Likes

Hi @marius, there is a firmware upgrade for the USB-C chip, that you can apply using a Windows VM. PicoPix Max USB-C firmware upgrade procedure.

If this doesn’t solve your issue, and you’ve also already tried different HDMI or USB-C cables, please request a warranty replacement. Video instability with MacBook Pro is not a general problem, and is not something solvable by an update of the Android system. Therefore if the above all fails to solve the problem, your unit might have a hardware defect.

2 Likes

I share your concerns. It’s good to see constant “work in progress” when it comes to updates. Nevertheless it would be convenient if some of the unsolved issues could get more attention or at least get some feedback on the status of handling these issues by Philips. A list with all reported issues by the community could be shared online with indications of status: work in progress, evaluation…
At least we would get a sense of how serious the issue is and when and how they are dealing with it.
Today a lot of issues are scattered and often duplicated in the community with little or no feedback from the Philips team.

Hi @PhilipsEngineering Prashant, thanks for your answer.
Yes, I tried different cables and got the same result. The firmware upgrade software gives me an error when I try to run it on a win10 machine, so it doesn’t work either.

How do I request a warranty replacement?

thanks

1 Like

I am getting a blank black screen after 1.2.1 update via online. Any suggestions please !

1 Like

@PhilipsEngineering

Hi! Any way to disable the bright No Signal screen?

Or perhaps change the background of the colour from bright yellow to black perhaps?

I am also just getting a back screen after the Philips logo splash screen. Nothing to do. Restarting results in the same issue.

Guess I will have to do a factory reset…

Wait, I can’t factory reset on the hardware itself? Not helpful when I can’t access any menus in the software either. Please help! :confused:

3 Likes

I cannot cast my android phone still. That problem is still there, I am connected to the same 5GHz network from my phone (android) and PicoPix, yet when I try to cast content from YouTube or my screen it doesn’t connect as it gives an error

Thank you. I will give that a try!

Hi @Mifuad, please go to AirPlay settings and turn off Google Cast. Then, start SmartYouTubeTV app on the projector, go to its settings and select Link with TV Code. Link the youtube app on your phone with this app on the projector. Let us know if this works.

If not, you can also try Miracast — select the Miracast icon from the home screen’s quick settings section, or select Android from the Settings app > Mirroring section.

@PhilipsEngineering Prashant, regarding the issue with the PicoPix going blank after being connected to macbook pro on either USB-C or HDMI … I did a factory reset and now IT’S WORKING:). It has been on for an hour so far.

Funny note - my mac is charging from PicoPix :))).

1 Like