Software Update v1.3.0 is now available

Dear PicoPix Max owners,

We are pleased to announce the release of system software V1.3.0.

The changes in this version are:

EasySetup is now included

You can run it manually, or it will start on first boot, helping you select the language, time zone, pair the remote and setup WiFi.

The projector now autofocuses on every boot

This nice convenience feature makes sure your projector is always in focus. But if your PicoPix is already perfectly focused and doesn’t move often, this feature can be disabled from Image Settings:

Other improvements

  • The Launcher has been updated to 1.8.3 with updated Philips typeface and bug fixes.
  • The recent bug with black screen after updating the launcher should be fixed.
  • Translation improvements, particularly with app update feature of the home screen.
  • Internal stability improvements.

We hope you enjoy this update!

2 Likes

It’s not working for me.

1.3.0 downloads to picopix but get an error when it try’s to extract.

‘Not a valid update package’

2 Likes

Same here…

I just downloaded it again and worked

the update does still not fix my issue from here

Well I had a pretty good run, but after this update my PPM is dead. Rockchip kernel screen, Philips logo, skinny circle, then endless black screen.

What do I do now?

I haven’t updated because I’m waiting for these feedbacks. When can we have a trouble-free update? :sweat_smile:

3 Likes

I used to install new updates immediately but recent quality issues have got me spooked. I may just leave the PPMax as it is and use it as a backup projector. But first, I gotta figure out how to replace the bloated battery :weary:

Have you tried asking for a replacement?

Is there a an app still in the works? I appreciate the Max has dropped off the dev priority list, but this update feels like the ticking along until EOL stuff now.

Love the PJ still, but hoping we get the app before it’s crossed off the list.

Cheers.

I have not asked. Been procrastinating. I forgot - is the warranty 1 or 2 years?

FAQ says 2 year from the date of reception.

1 Like

Thank you. I better ask for a replacement before Jan 2022 then.

Hi William, I am having police light when I turn on the charger. It’s blinking red and blue now. This happen after the latest update but maybe just a coincidence.

I am now stuck with the setup screen. After updating it takes to the setup screen asking to select language and timezone. The next screen is the language timezone screen. And then no option to continue or any button. If I click home it goes to home page and again to the setup screen. Looks like another bad update.

Update 1
The only way to access apps is to click home button and before the setup screen launches quickly click the settings icon. Then open apps from there. Tried to downgrade to 1.2.7 but offline upgrade but gives not a valid update package error

Update2
figured out the 1.2.7 zip had an update.zip inside. The installation aborted itself saying cannot install 1.2.7 over a later version. So will wait for a fix now

Update 3
Temporarily fixed it by turning off background activity in developer options

Hello Ronald, sorry to hear that. Does it still work or is it unable to charge anymore?

It’s still working but not sure for how long. Previously when first turned on, it will reflect 97% charged and slowly goes up to 100% as i am using it plugged in. Charging light appeared red and then become blue once fully charged.

Now the charger light blinking red/blue and it started off at 83% and won’t reach 100%.

I am quite concerned about the quality of the battery/projector.

Sadly that usually means something’s wrong the battery. I believe I experienced something similar on my old one. Check your battery, maybe it’s bloated too. It’s either the battery on PPM is really bad, overall hardware design of PPM is bad or battery bypass is simply not working.

Has anyone had a problem with the offline update for this version (v1.3.0)?

I updated it successfully, but since then apps got quit unexpectedly very frequently. Pretty sure this is the firmware issue since I didn’t encounter similar thing with the previous firmware version…