Trackpad has stopped working


I’ve had my PPX for three weeks now, and it was working ok up until yesterday when the cursor disappeared, both for the remote air mouse and the trackpad.

Does anyone know if there’s a way to re-enable this feature?


Does the trackpad still register 3 or 2 finger swipes?

Thanks - good question, and something I had not thought to check. I just tried it, and it doesn’t register 2 or 3 finger swipes either.

1 Like

Do the directional keys still work, can you navigate through the OS?

Yes, the directional keys on the remote work, and I can move throught the OS and open up apps. Unfortunately without the trackpad I can’t operate apps such as netflix (need to be able to click on actions using the cursors).

1 Like

How tech-savvy are you, and in which timezone are you?

I’m technically competent. Timezone is BST.

I powered up the projector today to test playing content via USB C. Before doing anything, I tried the touchpad and again there was no response.

Plugged in USB C cable, tested the device I was going to use as a source (didn’t work but that’s a limitation on that device it turns out). I then unplugged the cable…and the pointer came back.

So it’s now responding, touchpad is working, air remote is working…and seriously, the only thing I’ve done is plugged and unplugged a USB cable to the input port.

1 Like

Did you previously use that port? If you did, the system might have thought it was still in use somehow and blocked the mouse functions, as why would you need those if you’re using an external source.
If it happens again, please check the USB-C (VIDEO) port for any play or damage to the pins.

Hi Ivo,

No, I’ve never used that port before (or indeed any of them, I’ve been using the native media apps until the trackpad stopped)

…and then it stops working again, and nothing will get it start up again. Only changes have been re-enabling wifi, and also logging into netflix to download some content. I’ve disabled wifi, I’ve tried reconnect a usb cable, and no joy.

Had also emailed Philips but they’re not responding so I’m currently left with a $400 paper weight. This is why I stopped doing kickstarter/indiegogo - you take on a lot of risk, and get very little benefit.

This is not true Richard, we did send you an email on Wednesday with a link to the return form, have you seen that and replied to it?

1 Like

Yes. I replied on Wednesday, since when I’ve had nothing.

So today I called up the support line, to be advised that I should expect some sort of response within 30-40 days. I honestly thought the guy was joking at first, but apparently not. I really, really hope that he meant replacement units would be 30-40 days, but the collection form indicates the unit has to be returned before any replacement can be considered, so who knows.

1 Like

The full turnaround time from filling in form, getting shipping labels, scheduling pickup of your unit, shipping of unit, confirmation of arrival in Hong Kong, sending a new unit out to you, that all could take about 30-40 days yes.